summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2024-05-15 11:17:26 +0000
committerYixun Lan <dlan@gentoo.org>2024-05-15 11:18:18 +0000
commitb76f6ac322936f2f531b23f2e8d3b7d404aabbdd (patch)
tree67b346a5b33ddbc869922339b1e5b1c5f3c06668 /dev-libs
parentdev-libs/libgpiod: add 2.1.2 (diff)
downloadgentoo-b76f6ac322936f2f531b23f2e8d3b7d404aabbdd.tar.gz
gentoo-b76f6ac322936f2f531b23f2e8d3b7d404aabbdd.tar.bz2
gentoo-b76f6ac322936f2f531b23f2e8d3b7d404aabbdd.zip
dev-libs/libgpiod: drop 2.1
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libgpiod/Manifest1
-rw-r--r--dev-libs/libgpiod/libgpiod-2.1.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-libs/libgpiod/Manifest b/dev-libs/libgpiod/Manifest
index 3d3ec36a1b2d..48f717a3d179 100644
--- a/dev-libs/libgpiod/Manifest
+++ b/dev-libs/libgpiod/Manifest
@@ -2,4 +2,3 @@ DIST libgpiod-1.6.3.tar.xz 326068 BLAKE2B eda5409f2db3914ede92690589643211eca300
DIST libgpiod-1.6.4.tar.xz 334552 BLAKE2B 3bf52dab263638967e0f59c858e22f3d8ec1c9565ba1edd665dff580a883fbc6aa49a944e6df4da8fca9c2df873e222ed4e055c9792ee27d4562b3c2d0c65b79 SHA512 23ea27147039ae34505263dbfbb3ca9985fc671d26e489ccaf150543d4e853f709393f46a8a5a1e682fa91378163bd2db6c689159ef73c3a8d1eeea422eacda0
DIST libgpiod-2.1.1.tar.xz 421164 BLAKE2B 940f2af832a0fc39accecd9cf76864d05f961c0d2e4899d09dc07670bb2a8d8c2704fa43e29e2163f2b486ba65cadce2114f96cf0e7637afece99c543852305f SHA512 d396f1b8f632c3592b2be37e23e5052f4050ab5c1a9de77de5f97ce50fa3115c119dd69b0bbcf59621e92b775bfc81f18a65cca1e57e022752d28c0e01baff6f
DIST libgpiod-2.1.2.tar.xz 419964 BLAKE2B 62b1df3af28d0ab4988101f6bcbce750fd5bd7db874a34c196630bc8badaefc8e3c5c60bbf3c4dfff074d4d2f681d3339fc32c9eeecf395b595b91e5727572e5 SHA512 e921ac34692d5ae92a29592e2103229a8b0afcdcfa750e30fbd292554cd2e59fd51aefc8fa2ad1c9ad5ea4a93bb3443e8f6e8f4f1537109b263aba33317106f3
-DIST libgpiod-2.1.tar.xz 421132 BLAKE2B 97f43854070f19b37f4041c08d33c8156d69a3acd73845849f843223d159602ad8aa59096e1c8a3428bf16488272353a5747c6c95b9f729cb11e53ceeb6b29c2 SHA512 1c20a93fb2a6cf66f4690a5784ac1aeb077ca3da23c1942448f045972092468480e13b13174f327b3b7252bef5f23ffd226c990f11529b1151ba2dc318a47e52
diff --git a/dev-libs/libgpiod/libgpiod-2.1.ebuild b/dev-libs/libgpiod/libgpiod-2.1.ebuild
deleted file mode 100644
index d3c115ebeb62..000000000000
--- a/dev-libs/libgpiod/libgpiod-2.1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools linux-info
-
-DESCRIPTION="C library and tools for interacting with the linux GPIO character device"
-HOMEPAGE="https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/"
-SRC_URI="https://mirrors.edge.kernel.org/pub/software/libs/libgpiod/${P}.tar.xz"
-
-LICENSE="LGPL-2.1"
-# Reflects the ABI of libgpiod.so
-SLOT="0/3"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
-IUSE="+tools cxx python test"
-RESTRICT="!test? ( test )"
-
-# --enable-tests enable libgpiod tests [default=no]
-# --enable-bindings-cxx enable C++ bindings [default=no]
-# --enable-bindings-python
-# --enable-bindings-rust
-DEPEND="
- test? (
- >=dev-libs/glib-2.50
- >=sys-apps/kmod-18
- >=sys-apps/util-linux-2.33.1
- >=virtual/libudev-215
- )
-"
-
-PATCHES=(
- # bug 913899
- "${FILESDIR}"/${PN}-2.1-libtool.patch
-)
-
-pkg_setup() {
- CONFIG_CHECK="~GPIO_CDEV_V1"
- linux-info_pkg_setup
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myconf=(
- $(use_enable tools)
- $(use_enable cxx bindings-cxx)
- $(use_enable test tests)
- $(use_enable python bindings-python)
- --enable-examples
- --disable-profiling
- --disable-bindings-rust
- )
-
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
-
- find "${D}" -name '*.la' -type f -delete || die
- find "${D}" -name "*.a" -delete || die
-}