summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-12-23 22:46:08 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-12-23 22:51:20 +0100
commitced698bbf263237f8d80253e0f62f5ee8098c80e (patch)
treed60cfb117bf76cce888f4566cfa079641c7aeee2 /dev-lua
parentnet-dns/ddclient: add 3.11.2 (diff)
downloadgentoo-ced698bbf263237f8d80253e0f62f5ee8098c80e.tar.gz
gentoo-ced698bbf263237f8d80253e0f62f5ee8098c80e.tar.bz2
gentoo-ced698bbf263237f8d80253e0f62f5ee8098c80e.zip
dev-lua/luasystem: add 0.3.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luasystem/Manifest1
-rw-r--r--dev-lua/luasystem/luasystem-0.3.0.ebuild91
-rw-r--r--dev-lua/luasystem/metadata.xml1
3 files changed, 93 insertions, 0 deletions
diff --git a/dev-lua/luasystem/Manifest b/dev-lua/luasystem/Manifest
index c1feeb4a855b..75382dfd485e 100644
--- a/dev-lua/luasystem/Manifest
+++ b/dev-lua/luasystem/Manifest
@@ -1 +1,2 @@
DIST luasystem-0.2.1_p0.tar.gz 8162 BLAKE2B ad8a6009823ad8202ff3884a3167d0779405c2a6be460b7ef2939622eb4d0fc8edbc6b04aba5dec9dd5e4e38f11ae0dcd582b9c348d5b516aa411858d55c6d71 SHA512 9dc323d4d1914cfa4f278a49ef22e58569d5cd7e369fa17fa6006cd47f9d90c6dfd4404067ea2436aa46a27cfbdf91e4aa26e20b89aeeefdf2aa7252c51fb32b
+DIST luasystem-0.3.0.tar.gz 19607 BLAKE2B 82dd54dab61045d25d9d1dc074526c2443b9732adf27da052f65702f0941a04dce65582091b5ecb802e5aed9baa2f4dbd53e4cd1b624426341a83fbcb0109378 SHA512 1adf1167767d7d8233ed2c90c106b050dc2370e891465eeb13f16ebc96e8f467d67a89a40173064112117ac9db2451aa73fde0d11fab01f6d2c56bdef50cb6ac
diff --git a/dev-lua/luasystem/luasystem-0.3.0.ebuild b/dev-lua/luasystem/luasystem-0.3.0.ebuild
new file mode 100644
index 000000000000..ee1ca807ef71
--- /dev/null
+++ b/dev-lua/luasystem/luasystem-0.3.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+MY_PV="${PV/_p/-}"
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Platform independent system calls for Lua"
+HOMEPAGE="https://github.com/lunarmodules/luasystem"
+SRC_URI="https://github.com/lunarmodules/${PN}/archive/refs/tags/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-lua/busted[${LUA_USEDEP}]
+ dev-lua/lua_cliargs[${LUA_USEDEP}]
+ ${RDEPEND}
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.2.1_p0-fix-makefile.patch )
+
+src_prepare() {
+ default
+
+ lua_copy_sources
+}
+
+lua_src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "LD=$(tc-getCC)"
+ "LUAINC_linux=$(lua_get_include_dir)"
+ "MYCFLAGS=${CFLAGS}"
+ "MYLDFLAGS=${LDFLAGS}"
+ )
+
+ emake "${myemakeargs[@]}" linux
+
+ popd
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_install () {
+ pushd "${BUILD_DIR}" || die
+
+ local emakeargs=(
+ "INSTALL_TOP_CDIR=${ED}/$(lua_get_cmod_dir)"
+ "INSTALL_TOP_LDIR=${ED}/$(lua_get_lmod_dir)"
+ "LUA_INC=${ED}/$(lua_get_include_dir)"
+ )
+
+ emake "${emakeargs[@]}" install
+
+ insinto $(lua_get_lmod_dir)/system
+ doins system/init.lua
+
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}
diff --git a/dev-lua/luasystem/metadata.xml b/dev-lua/luasystem/metadata.xml
index 7f9fa1b5f4a9..4d95a0681768 100644
--- a/dev-lua/luasystem/metadata.xml
+++ b/dev-lua/luasystem/metadata.xml
@@ -15,5 +15,6 @@
</longdescription>
<upstream>
<remote-id type="github">LuaDist2/luasystem</remote-id>
+ <remote-id type="github">lunarmodules/luasystem</remote-id>
</upstream>
</pkgmetadata>