summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2024-05-16 12:45:00 +0200
committerFabian Groffen <grobian@gentoo.org>2024-05-16 12:45:00 +0200
commit090ed2a4929b22259772d8d9bc0f55d1c5e3ca5a (patch)
tree571c43e8cc6fc696194808234d726cbf3914e303 /dev-python
parentapp-admin/exo: remove old (diff)
downloadgentoo-090ed2a4929b22259772d8d9bc0f55d1c5e3ca5a.tar.gz
gentoo-090ed2a4929b22259772d8d9bc0f55d1c5e3ca5a.tar.bz2
gentoo-090ed2a4929b22259772d8d9bc0f55d1c5e3ca5a.zip
dev-python/carbon: remove last-rited package
Closes: https://bugs.gentoo.org/929444 Closes: https://bugs.gentoo.org/798312 Closes: https://bugs.gentoo.org/677024 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/carbon/Manifest1
-rw-r--r--dev-python/carbon/carbon-1.1.10.ebuild61
-rw-r--r--dev-python/carbon/files/carbon.confd5
-rw-r--r--dev-python/carbon/files/carbon.initd253
-rw-r--r--dev-python/carbon/metadata.xml15
5 files changed, 0 insertions, 135 deletions
diff --git a/dev-python/carbon/Manifest b/dev-python/carbon/Manifest
deleted file mode 100644
index 167ab4cf755d..000000000000
--- a/dev-python/carbon/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST carbon-1.1.10.tar.gz 77091 BLAKE2B 367beb81a4dcf4c5fff6bf9884c7accb8aea9daa88d6d890bb977c926268b7ae041c9ac8e4b537f07d08d6c970f536ccc87ae6b4caef555883aadeab155fedce SHA512 a5c8d730e311bb65682c701b79a5e3e02e35eec5c0d923fece3f63d7036ca1f85775100fba9a2090487f2cf75bae7708dae9580deccd8fc586f2820b03e14b4c
diff --git a/dev-python/carbon/carbon-1.1.10.ebuild b/dev-python/carbon/carbon-1.1.10.ebuild
deleted file mode 100644
index 72cc0318ec8d..000000000000
--- a/dev-python/carbon/carbon-1.1.10.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Backend data caching and persistence daemon for Graphite"
-HOMEPAGE="https://graphiteapp.org/"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="~amd64 ~x86"
-
-# whisper appears to have been missed from listing in install_requires in setup.py
-RDEPEND="
- dev-python/twisted[${PYTHON_USEDEP}]
- dev-python/cachetools[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- =dev-python/whisper-${PV}*[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- # Do not install the configuration and data files. We install them
- # somewhere sensible by hand.
- sed -i -e '/data_files=install_files,/d' setup.py || die
- # We want FHS-style paths instead of /opt/graphite
- export GRAPHITE_NO_PREFIX=yes
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /etc/carbon
- doins conf/*
-
- keepdir /var/log/carbon /var/lib/carbon/{whisper,lists,rrd}
-
- newinitd "${FILESDIR}"/carbon.initd2 carbon-cache
- newinitd "${FILESDIR}"/carbon.initd2 carbon-relay
- newinitd "${FILESDIR}"/carbon.initd2 carbon-aggregator
-
- newconfd "${FILESDIR}"/carbon.confd carbon-cache
- newconfd "${FILESDIR}"/carbon.confd carbon-relay
- newconfd "${FILESDIR}"/carbon.confd carbon-aggregator
-}
-
-pkg_postinst() {
- einfo 'This ebuild installs carbon into FHS-style paths.'
- einfo 'You will probably have to set GRAPHITE_CONF_DIR to /etc/carbon'
- einfo 'and GRAPHITE_STORAGE_DIR to /var/lib/carbon to make use of this'
- einfo '(see /etc/carbon/carbon.conf.example).'
- einfo ' '
- einfo 'OpenRC init script supports multiple instances !'
- einfo 'Example to run an instance b of carbon-cache :'
- einfo ' ln -s /etc/init.d/carbon-cache /etc/init.d/carbon-cache.b'
- einfo ' cp /etc/conf.d/carbon-cache /etc/conf.d/carbon-cache.b'
-}
diff --git a/dev-python/carbon/files/carbon.confd b/dev-python/carbon/files/carbon.confd
deleted file mode 100644
index b1875e134678..000000000000
--- a/dev-python/carbon/files/carbon.confd
+++ /dev/null
@@ -1,5 +0,0 @@
-# Use the given config file
-CARBON_CONFIG="/etc/carbon/carbon.conf"
-
-# Add extra parameters
-CARBON_EXTRA_PARAMETERS=""
diff --git a/dev-python/carbon/files/carbon.initd2 b/dev-python/carbon/files/carbon.initd2
deleted file mode 100644
index ff1509747ef1..000000000000
--- a/dev-python/carbon/files/carbon.initd2
+++ /dev/null
@@ -1,53 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-export GRAPHITE_CONF_DIR=/etc/carbon
-export GRAPHITE_STORAGE_DIR=/var/lib/carbon
-
-INSTANCE=${SVCNAME#*.}
-if [ "${INSTANCE}" = "${SVCNAME}" ]; then
- INSTANCE="a"
-fi
-
-PIDFILE="/var/run/${SVCNAME}.pid"
-PROGRAMNAME=${SVCNAME%%.*}
-
-CARBON_CONFIG=${CARBON_CONFIG:-/etc/carbon/carbon.conf}
-
-depend() {
- use net
-}
-
-
-start_pre() {
- if [ ! -f ${CARBON_CONFIG} ] ; then
- eend "Missing ${CARBON_CONFIG}"
- fi
- case "${PROGRAMNAME}" in
- "carbon-relay" )
- if `grep -q "^RELAY_METHOD = rules$" ${CARBON_CONFIG}`; then
- [ -f /etc/carbon/relay-rules.conf ] || eend "Missing relay-rules.conf"
- fi
- ;;
- "carbon-aggregator" )
- [ -f /etc/carbon/aggregation-rules.conf ] || eend "Missing missing aggregation-rules.conf"
- ;;
- esac
-}
-
-start() {
- ebegin "Starting ${PROGRAMNAME} instance ${INSTANCE}"
- start-stop-daemon --start --exec /usr/bin/${PROGRAMNAME}.py \
- --pidfile ${PIDFILE} \
- -- --pidfile ${PIDFILE} --instance ${INSTANCE} \
- --logdir /var/log/carbon/ --config ${CARBON_CONFIG} start >/dev/null
- eend $? "Failed to start ${SVCNAME}"
-}
-
-stop() {
- ebegin "Stopping ${PROGRAMNAME} instance ${INSTANCE}"
- start-stop-daemon --stop \
- --pidfile ${PIDFILE}
- eend $? "Failed to stop ${SVCNAME}"
-}
diff --git a/dev-python/carbon/metadata.xml b/dev-python/carbon/metadata.xml
deleted file mode 100644
index d38ab1927158..000000000000
--- a/dev-python/carbon/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>patrick@gentoo.org</email>
- <name>Patrick Lauer</name>
- </maintainer>
- <maintainer type="person">
- <email>grobian@gentoo.org</email>
- <name>Fabian Groffen</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">carbon</remote-id>
- </upstream>
-</pkgmetadata>