summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-15 03:50:49 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-15 03:50:49 +0200
commit1fc7b958e662efa67e7fbbc13cf031f351054d0e (patch)
treee3ce3fb1ccf1b43604a7c54866326713aa3c4f6a /dev-python
parentdev-python/pyproject-fmt-rust: Bump to 1.1.0 (diff)
downloadgentoo-1fc7b958e662efa67e7fbbc13cf031f351054d0e.tar.gz
gentoo-1fc7b958e662efa67e7fbbc13cf031f351054d0e.tar.bz2
gentoo-1fc7b958e662efa67e7fbbc13cf031f351054d0e.zip
dev-python/cssutils: Bump to 2.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cssutils/Manifest1
-rw-r--r--dev-python/cssutils/cssutils-2.11.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/cssutils/Manifest b/dev-python/cssutils/Manifest
index c57f13e933f6..3911c03aef36 100644
--- a/dev-python/cssutils/Manifest
+++ b/dev-python/cssutils/Manifest
@@ -1,2 +1,3 @@
DIST cssutils-2.10.2.tar.gz 723055 BLAKE2B 7064f1928bf8496bef8eccf4663f944ed79e5e8065808254d12b68f32e9c8f308724e652b24fa584af54a0976ff3ab2f2751a9102e0f31a5f4a8fabf8f417b23 SHA512 c678b6953b13e8a7ac7b2abbe0b8be26283973537089071828e618b359bcce27df636f382d8b0dc50b13962e0d2dffcce991a47f678954ec018849e57026446d
DIST cssutils-2.10.3.tar.gz 723334 BLAKE2B 3ee122fb843aeb8db79d5288d465fda4f632e63a51e09a9de7d1429b1e7a81de93518eb1c4766b7a18c7db3fb64480815fd3a8c22b9b4a4186890402328f1b42 SHA512 44570c048d64d9d2825f64c551470d86fd5a166c35fef7915e9187ba26807300c342360aa881fc4f7ed86ef7aba63969d5055811f5ecae4b3998bf4b28ffd5ea
+DIST cssutils-2.11.0.tar.gz 723164 BLAKE2B 433358b1bd167d72ceda9c60f4460a95804c492a92854747dfc49ef4e2efe69388781c515adbb3c5d9010895e13a039ea33c46d4b2c71cb8bb15eead3e998b60 SHA512 42ce87502757d213ab5b2812c8a76724955f565826c69ffe4db53d49020ce960c8544423428f2b8c24d9b1b215c22f18de9dff66ef249c8060d17aad990d9a6f
diff --git a/dev-python/cssutils/cssutils-2.11.0.ebuild b/dev-python/cssutils/cssutils-2.11.0.ebuild
new file mode 100644
index 000000000000..ed12fc16c300
--- /dev/null
+++ b/dev-python/cssutils/cssutils-2.11.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A CSS Cascading Style Sheets library"
+HOMEPAGE="
+ https://pypi.org/project/cssutils/
+ https://github.com/jaraco/cssutils/
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-test-5.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/lxml[${PYTHON_USEDEP}]
+ ' 3.10)
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # network
+ encutils/__init__.py::encutils
+ examples/website.py::examples.website.logging
+ )
+ local EPYTEST_IGNORE=(
+ # path mismatch with "parse" package
+ examples/parse.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m "not network"
+}