summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-14 18:15:06 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-14 18:15:06 +0200
commit50c9aa1d85815aa21b07066b1760c1dc60ab15b6 (patch)
treedd5edf9a448c5924975fe6ec771e99d63da4dd76 /dev-python
parentdev-python/sniffio: Enable py3.13 (diff)
downloadgentoo-50c9aa1d85815aa21b07066b1760c1dc60ab15b6.tar.gz
gentoo-50c9aa1d85815aa21b07066b1760c1dc60ab15b6.tar.bz2
gentoo-50c9aa1d85815aa21b07066b1760c1dc60ab15b6.zip
dev-python/anyio: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/anyio/anyio-4.3.0-r1.ebuild26
1 files changed, 23 insertions, 3 deletions
diff --git a/dev-python/anyio/anyio-4.3.0-r1.ebuild b/dev-python/anyio/anyio-4.3.0-r1.ebuild
index 5636aa635281..b4a410314649 100644
--- a/dev-python/anyio/anyio-4.3.0-r1.ebuild
+++ b/dev-python/anyio/anyio-4.3.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
inherit distutils-r1 pypi
@@ -35,8 +35,10 @@ BDEPEND="
>=dev-python/hypothesis-4.0[${PYTHON_USEDEP}]
>=dev-python/psutil-5.9[${PYTHON_USEDEP}]
>=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
- >=dev-python/trio-0.23[${PYTHON_USEDEP}]
dev-python/trustme[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/trio-0.23[${PYTHON_USEDEP}]
+ ' 3.{10..12})
amd64? (
$(python_gen_cond_dep '
>=dev-python/uvloop-0.17[${PYTHON_USEDEP}]
@@ -57,6 +59,24 @@ python_test() {
tests/test_sockets.py::TestTCPListener::test_bind_link_local
)
+ local filter=()
+ if ! has_version ">=dev-python/trio-0.23[${PYTHON_USEDEP}]"; then
+ filter+=( -k "not trio" )
+ EPYTEST_DESELECT+=(
+ tests/test_pytest_plugin.py::test_plugin
+ tests/test_pytest_plugin.py::test_autouse_async_fixture
+ tests/test_pytest_plugin.py::test_cancel_scope_in_asyncgen_fixture
+ )
+ fi
+
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ 'tests/test_fileio.py::TestPath::test_properties[asyncio]'
+ )
+ ;;
+ esac
+
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -m 'not network'
+ epytest -m 'not network' "${filter[@]}"
}