summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-03-19 15:07:34 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-03-19 15:07:34 +0100
commit490a17af5db5ccb57a6055ba941cf48a5a758be7 (patch)
tree0106fb11e2153e1a09b9534b404cf20597d531cf /dev-tex
parenttexlive-common.eclass: etexmf-update to call 'die' for non-"dev-telive" (diff)
downloadgentoo-490a17af5db5ccb57a6055ba941cf48a5a758be7.tar.gz
gentoo-490a17af5db5ccb57a6055ba941cf48a5a758be7.tar.bz2
gentoo-490a17af5db5ccb57a6055ba941cf48a5a758be7.zip
dev-tex/hevea: call etexmf-update instead of custom logic
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/hevea/hevea-2.36.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/dev-tex/hevea/hevea-2.36.ebuild b/dev-tex/hevea/hevea-2.36.ebuild
index 51948f1e861c..77d7572fe0a6 100644
--- a/dev-tex/hevea/hevea-2.36.ebuild
+++ b/dev-tex/hevea/hevea-2.36.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit texlive-common
+
DESCRIPTION="HeVeA is a quite complete and fast LaTeX to HTML translator"
HOMEPAGE="https://hevea.inria.fr/"
SRC_URI="https://hevea.inria.fr/distri/${P}.tar.gz"
@@ -58,13 +60,9 @@ src_install() {
# If latex is installed later, it will see hevea.sty
pkg_postinst() {
- if [[ -z "${ROOT}" ]] && [[ -x "${EPREFIX}"/usr/sbin/texmf-update ]] ; then
- "${EPREFIX}"/usr/sbin/texmf-update || die "texmf-update returned non-zero exit status ${?}"
- fi
+ etexmf-update
}
pkg_postrm() {
- if [[ -z "${ROOT}" ]] && [[ -x "${EPREFIX}"/usr/sbin/texmf-update ]] ; then
- "${EPREFIX}"/usr/sbin/texmf-update || die "texmf-update returned non-zero exit status ${?}"
- fi
+ etexmf-update
}