summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2021-02-20 13:38:17 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-23 13:01:23 +0300
commit573045d03f5a1bdb2fdfd7bb7fbd08fbf4c5e838 (patch)
tree9a3d6f6012228419cf8c3865efc4b925d63c983a /dev-util
parentdev-util/dissembler: EAPI 6 -> 8 (diff)
downloadgentoo-573045d03f5a1bdb2fdfd7bb7fbd08fbf4c5e838.tar.gz
gentoo-573045d03f5a1bdb2fdfd7bb7fbd08fbf4c5e838.tar.bz2
gentoo-573045d03f5a1bdb2fdfd7bb7fbd08fbf4c5e838.zip
dev-util/dropwatch: version bump to 1.5.4, live ebuild, wrt #699142
Closes: https://bugs.gentoo.org/699142 Signed-off-by: Vladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua> Closes: https://github.com/gentoo/gentoo/pull/19556 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/dropwatch/Manifest1
-rw-r--r--dev-util/dropwatch/dropwatch-1.5.4.ebuild38
-rw-r--r--dev-util/dropwatch/metadata.xml10
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/dropwatch/Manifest b/dev-util/dropwatch/Manifest
index 64fdc897acf3..dadf0aa2bc72 100644
--- a/dev-util/dropwatch/Manifest
+++ b/dev-util/dropwatch/Manifest
@@ -1 +1,2 @@
DIST dropwatch-1.4_p20150706.tar.xz 14880 BLAKE2B 4df44a517447a7e99fe5d84a79421c9810c3b67524eb1d208c36ebb503dd43c715e57c678c33a90689707680d1f42b9d30d00080894f22889553e551a23adfa6 SHA512 f78f19f063408cb655869e662e92709b1cec820ab35b11272b87a990c380e0799c6e9067dcf53edab795916347dfe3fd04932f9699c3f5649f96d62567957fbd
+DIST dropwatch-1.5.4.gh.tar.gz 24774 BLAKE2B 36cd3fa3e2afc755cb5b34d43c31424ba176db4e6c83894e6bb97e458e214638fa69ec692b8fed84befbb01fd969c04d4d1c7374e82dfcec1a512f4e9e00d86d SHA512 4af06c05c694d4a044a5e92ba9869a865730bb2caa28cddc33160481f490ed77a7300ef57c9f76722d7bc8d4ac47cdfd5f13daf4f764500f3c90a72b5ee58d61
diff --git a/dev-util/dropwatch/dropwatch-1.5.4.ebuild b/dev-util/dropwatch/dropwatch-1.5.4.ebuild
new file mode 100644
index 000000000000..5a03257c4af2
--- /dev/null
+++ b/dev-util/dropwatch/dropwatch-1.5.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info
+
+DESCRIPTION="Monitor for dropped network packets"
+HOMEPAGE="https://github.com/nhorman/dropwatch"
+SRC_URI="https://github.com/nhorman/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bfd"
+
+RDEPEND="
+ dev-libs/libnl:3
+ net-libs/libpcap
+ sys-libs/readline:=
+ bfd? ( sys-libs/binutils-libs:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~NET_DROP_MONITOR"
+
+src_prepare() {
+ default
+
+ sed -e '/AM_CFLAGS/s/-Werror //' -i src/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf "$(use_with bfd)"
+}
diff --git a/dev-util/dropwatch/metadata.xml b/dev-util/dropwatch/metadata.xml
index 115e9d64a669..7bebac60453c 100644
--- a/dev-util/dropwatch/metadata.xml
+++ b/dev-util/dropwatch/metadata.xml
@@ -2,4 +2,14 @@
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
+ <longdescription>
+ Utility to diagnose problems in the Linux Networking stack, specifically
+ where packets are getting dropped.
+ </longdescription>
+ <use>
+ <flag name="bfd">Add support for Binary File Descriptor</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">nhorman/dropwatch</remote-id>
+ </upstream>
</pkgmetadata>