summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/postalplus
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/postalplus')
-rw-r--r--games-action/postalplus/metadata.xml5
-rw-r--r--games-action/postalplus/postalplus-1.ebuild38
2 files changed, 43 insertions, 0 deletions
diff --git a/games-action/postalplus/metadata.xml b/games-action/postalplus/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-action/postalplus/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-action/postalplus/postalplus-1.ebuild b/games-action/postalplus/postalplus-1.ebuild
new file mode 100644
index 000000000000..e3f06d89f7b9
--- /dev/null
+++ b/games-action/postalplus/postalplus-1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils cdrom games
+
+DESCRIPTION="Ultraviolent and controversial game featuring the Postal Dude"
+HOMEPAGE="http://www.lokigames.com/products/postal/"
+SRC_URI=""
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RESTRICT="strip"
+
+S=${WORKDIR}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
+ cdrom_get_cds postal_plus.ini
+ exeinto "${dir}"
+ doexe "${CDROM_ROOT}"/bin/x86/postal
+ insinto "${dir}"
+ doins "${CDROM_ROOT}"/{icon.{bmp,xpm},postal_plus.ini,README}
+ cp "${CDROM_ROOT}"/icon.xpm ${PN}.xpm || die
+
+ cp -r "${CDROM_ROOT}"/res "${D}${dir}" || die
+ find "${D}" -name TRANS.TBL -exec rm '{}' +
+
+ games_make_wrapper ${PN} ./postal "${dir}"
+ doicon ${PN}.xpm
+ make_desktop_entry ${PN} "Postal Plus" ${PN}
+
+ prepgamesdirs
+}