summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-01-26 16:32:43 -0600
committerAustin English <wizardedit@gentoo.org>2017-01-27 13:44:11 -0600
commit7e90bf893a1263777bc60c63b607402206944b53 (patch)
treea60ca72fc7720d1a46747af1ac37202a59011b93 /games-action/postalplus
parentgames-action/phobiaii: remove deprecated games eclass (diff)
downloadgentoo-7e90bf893a1263777bc60c63b607402206944b53.tar.gz
gentoo-7e90bf893a1263777bc60c63b607402206944b53.tar.bz2
gentoo-7e90bf893a1263777bc60c63b607402206944b53.zip
games-action/postalplus: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: Portage-2.3.2, Repoman-2.3.1
Diffstat (limited to 'games-action/postalplus')
-rw-r--r--games-action/postalplus/postalplus-1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-action/postalplus/postalplus-1-r1.ebuild b/games-action/postalplus/postalplus-1-r1.ebuild
new file mode 100644
index 000000000000..1afc394430d9
--- /dev/null
+++ b/games-action/postalplus/postalplus-1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils cdrom
+
+DESCRIPTION="Ultraviolent and controversial game featuring the Postal Dude"
+HOMEPAGE="http://www.lokigames.com/products/postal/"
+SRC_URI=""
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RESTRICT="strip"
+
+S=${WORKDIR}
+
+src_install() {
+ local dir=/opt/${PN}
+
+ cdrom_get_cds postal_plus.ini
+ exeinto "${dir}"
+ doexe "${CDROM_ROOT}"/bin/x86/postal
+ insinto "${dir}"
+ doins "${CDROM_ROOT}"/{icon.{bmp,xpm},postal_plus.ini,README}
+ cp "${CDROM_ROOT}"/icon.xpm ${PN}.xpm || die
+
+ cp -r "${CDROM_ROOT}"/res "${D}${dir}" || die
+ find "${D}" -name TRANS.TBL -exec rm '{}' + || die
+
+ make_wrapper ${PN} ./postal "${dir}"
+ doicon ${PN}.xpm
+ make_desktop_entry ${PN} "Postal Plus" ${PN}
+}