summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-17 23:32:10 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-17 23:45:45 -0400
commit01d58fbb4e74a9dcaa29d2a5a0f36fefe433f012 (patch)
tree51b9109639a751599d503e46a9567c78f64bd5d0 /games-board/gnome-chess
parentdev-lang/vala: Version bump to 0.52.2 (diff)
downloadgentoo-01d58fbb4e74a9dcaa29d2a5a0f36fefe433f012.tar.gz
gentoo-01d58fbb4e74a9dcaa29d2a5a0f36fefe433f012.tar.bz2
gentoo-01d58fbb4e74a9dcaa29d2a5a0f36fefe433f012.zip
games-board/gnome-chess: Version bump to 40.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'games-board/gnome-chess')
-rw-r--r--games-board/gnome-chess/Manifest1
-rw-r--r--games-board/gnome-chess/gnome-chess-40.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/games-board/gnome-chess/Manifest b/games-board/gnome-chess/Manifest
index 34ba4648c7e6..6c99f370c2cb 100644
--- a/games-board/gnome-chess/Manifest
+++ b/games-board/gnome-chess/Manifest
@@ -1 +1,2 @@
DIST gnome-chess-3.36.1.tar.xz 738308 BLAKE2B 14d328b9939afb12f14b513cfa009e3fb197f6c35c5272df107ce844890339caecbb5dafbd0bd28a19d001ebc0574464b33ea2ca10a9f7578b49d1e6f637e190 SHA512 4c89f91fe16323a799cf1eb3fe1f8e37fd506248ca32ad605ca3d5ecd37cf29f046da50383e0d0c3d82acf4e472843f3fd40927283f37e02d42cee5d8c72d8b3
+DIST gnome-chess-40.1.tar.xz 741168 BLAKE2B 3691f7aa03532456f9437588641417af4db45b99ffb0f211eca8dffd7a7ba7cf834c7f1e3e2cf6933df96c05b981edb7db3aac430be2c7256d96fca6ecb73db4 SHA512 aae1690724c068717045d70f4fbd5a6cf1fc169ae0bd5df0ae7f0d7a2609c93c482da545008dd3c5d11e975ec8f2c5fc6f4b0007a8f2a1128a75aec2f3fcb083
diff --git a/games-board/gnome-chess/gnome-chess-40.1.ebuild b/games-board/gnome-chess/gnome-chess-40.1.ebuild
new file mode 100644
index 000000000000..d0026406ab65
--- /dev/null
+++ b/games-board/gnome-chess/gnome-chess-40.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+VALA_MIN_API_VERSION="0.52"
+
+inherit gnome.org gnome2-utils meson python-any-r1 readme.gentoo-r1 vala xdg
+
+DESCRIPTION="Play the classic two-player boardgame of chess"
+HOMEPAGE="https://wiki.gnome.org/Apps/Chess"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ gui-libs/gtk:4
+ >=gnome-base/librsvg-2.46.0:2
+"
+DEPEND="${RDEPEND}
+ gnome-base/librsvg:2[vala]
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(vala_depend)
+ dev-util/itstool
+ dev-libs/appstream-glib
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="To be able to play against a computer you will need
+to install a chess engine package, for example games-board/gnuchess"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}