summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-01-10 18:16:11 -0500
committerMatt Turner <mattst88@gentoo.org>2023-01-10 18:17:34 -0500
commit55c36ef2085fb60f5ea254966248f7bb2bcac058 (patch)
tree4ea0c79c8567f9a8f5041608bb7d39bc0dc9c142 /games-board/gnome-chess
parentsys-libs/glibc: Fix automagic Perl dependency that breaks Prefix QA checks (diff)
downloadgentoo-55c36ef2085fb60f5ea254966248f7bb2bcac058.tar.gz
gentoo-55c36ef2085fb60f5ea254966248f7bb2bcac058.tar.bz2
gentoo-55c36ef2085fb60f5ea254966248f7bb2bcac058.zip
games-board/gnome-chess: Version bump to 43.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'games-board/gnome-chess')
-rw-r--r--games-board/gnome-chess/Manifest1
-rw-r--r--games-board/gnome-chess/gnome-chess-43.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/games-board/gnome-chess/Manifest b/games-board/gnome-chess/Manifest
index c65ebb75fbc6..a0630267f84b 100644
--- a/games-board/gnome-chess/Manifest
+++ b/games-board/gnome-chess/Manifest
@@ -1 +1,2 @@
DIST gnome-chess-43.0.tar.xz 658156 BLAKE2B eb8ddd9966a38ff385a93456621f250adaac1aee580475a136dc33d3182d0a772d50c2bc4bc47981e3b0dcf86ed91a2c8792ab682a5f6af4904a8f075fd520d5 SHA512 710ff09d9f5e23bb3822a203c1f5b11b85e8aa602f7c703f08e7843a79476498ec836e41122f6d601183b7220618bf2f2a2f0dcff62bcb625ae28b20a03d02c8
+DIST gnome-chess-43.1.tar.xz 743100 BLAKE2B b2fb2594cab3d0fa82d682db931911c71df9f4fca0707c39a15c5f5caa397a34e6a132e09950fb41ece01873a87d60e91df1e5397830cfa700427e3b119c95cc SHA512 d42fb3f960030813d2551c2f0dac46068f30992934e9f8779a097a1ca43a7711b64c0f499eff3ecd698325f5e2458f03c0a9b6cd4c333ad4ca9dba83faa833c5
diff --git a/games-board/gnome-chess/gnome-chess-43.1.ebuild b/games-board/gnome-chess/gnome-chess-43.1.ebuild
new file mode 100644
index 000000000000..ffb3da44acf5
--- /dev/null
+++ b/games-board/gnome-chess/gnome-chess-43.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson readme.gentoo-r1 vala xdg
+
+DESCRIPTION="Play the classic two-player boardgame of chess"
+HOMEPAGE="https://wiki.gnome.org/Apps/Chess https://gitlab.gnome.org/GNOME/gnome-chess"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ gui-libs/gtk:4
+ >=gui-libs/libadwaita-1.0.0:1
+ >=gnome-base/librsvg-2.46.0:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}
+ gnome-base/librsvg:2[vala]
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(vala_depend)
+ dev-util/itstool
+ dev-libs/appstream-glib
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="To be able to play against a computer you will need
+to install a chess engine package, for example games-board/gnuchess"
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}