summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-04-23 00:29:01 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-04-23 00:45:17 -0400
commit431f725f7c25210a360bee09eca37826e38414c4 (patch)
tree18485d92268593489feddf6e2ceecffc65bf6190 /games-board/tetzle
parentmedia-libs/rubberband: fixed boost dep use flags (diff)
downloadgentoo-431f725f7c25210a360bee09eca37826e38414c4.tar.gz
gentoo-431f725f7c25210a360bee09eca37826e38414c4.tar.bz2
gentoo-431f725f7c25210a360bee09eca37826e38414c4.zip
games-board/tetzle: add 2.2.2 (Qt6-only, masked)
Haven't really at bug #791769 for the old version, but this one hard-requires QtOpenGL and shouldn't be affected. Should be closed whenever Qt6 is unmasked. Drops ~x86 due to Qt6 for now. Bug: https://bugs.gentoo.org/791769 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-board/tetzle')
-rw-r--r--games-board/tetzle/Manifest1
-rw-r--r--games-board/tetzle/tetzle-2.2.2.ebuild18
2 files changed, 19 insertions, 0 deletions
diff --git a/games-board/tetzle/Manifest b/games-board/tetzle/Manifest
index 4a67b0579184..531a46fec772 100644
--- a/games-board/tetzle/Manifest
+++ b/games-board/tetzle/Manifest
@@ -1 +1,2 @@
DIST tetzle-2.1.3-src.tar.bz2 1022680 BLAKE2B 197e2a221a779734d3cd76d5600460df42014a31a032fca2f5c181d54c004f56e6beb9803c60fd53edf5b0d4a614b3d0709fd8913d561e49a938a2f6f1943001 SHA512 6f4541ad2f67ac8a98bd0e1683d4cb6131a85a4e9d31a9dae0a97177a721038750f4276fb3a592b97804daceb1b99f0117e14c6221a6a6ce74b852b00ed5c607
+DIST tetzle-2.2.2.tar.bz2 1094634 BLAKE2B 9fa50b6d691226f1b3526361e141f7ef566d9eea7db72b9d825afd52ae312cbb3b794e427014f427518da2a6fac0adf32bc0a557246042079fc0a2693ee68e34 SHA512 1aee8b110acd496cd885a207a4d229840f9c3f6960ed16b2f6a2c1f452f6234e4d88429c0276affb7e8c486d18b64ab36ada9cddcb006c4c56284216b5351891
diff --git a/games-board/tetzle/tetzle-2.2.2.ebuild b/games-board/tetzle/tetzle-2.2.2.ebuild
new file mode 100644
index 000000000000..7e6891c9b725
--- /dev/null
+++ b/games-board/tetzle/tetzle-2.2.2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Jigsaw puzzle game that uses tetrominoes for the pieces"
+HOMEPAGE="https://gottcode.org/tetzle/"
+SRC_URI="https://gottcode.org/tetzle/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-qt/qtbase:6[gui,opengl,widgets]"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/qttools:6[linguist]"