summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/tetzle
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/tetzle')
-rw-r--r--games-board/tetzle/Manifest1
-rw-r--r--games-board/tetzle/metadata.xml5
-rw-r--r--games-board/tetzle/tetzle-2.0.3.ebuild53
3 files changed, 59 insertions, 0 deletions
diff --git a/games-board/tetzle/Manifest b/games-board/tetzle/Manifest
new file mode 100644
index 000000000000..c688a8c47982
--- /dev/null
+++ b/games-board/tetzle/Manifest
@@ -0,0 +1 @@
+DIST tetzle-2.0.3-src.tar.bz2 641065 SHA256 6c29ea61501dcc0149ece879217df5710d1169bfae940a667af2a19605415b51 SHA512 39853cc37b0bae676fc516e56c2bb6a54d5cacccd5978d5bd9cd735bf9fcb09948871af06cdb3b3d1a510c51ea71ac3720bbfe2558c2effaa00e00708a70f7d9 WHIRLPOOL 7bc9d4973deb2b9d1b32316c40b13203d0dcab244d1805639c640331b4b582e0a81d821987a8e0275cd28edc59d9e419b03b7280efb0d7e55d5057398c94d4c9
diff --git a/games-board/tetzle/metadata.xml b/games-board/tetzle/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-board/tetzle/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-board/tetzle/tetzle-2.0.3.ebuild b/games-board/tetzle/tetzle-2.0.3.ebuild
new file mode 100644
index 000000000000..b211cd3cff09
--- /dev/null
+++ b/games-board/tetzle/tetzle-2.0.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit qt4-r2 gnome2-utils games
+
+DESCRIPTION="A jigsaw puzzle game that uses tetrominoes for the pieces"
+HOMEPAGE="http://gottcode.org/tetzle/"
+SRC_URI="http://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=dev-qt/qtgui-4.7:4
+ >=dev-qt/qtopengl-4.7:4"
+RDEPEND="${DEPEND}"
+
+DOCS="ChangeLog CREDITS"
+
+src_prepare() {
+ sed -i \
+ -e "s:appdir + \"/../share/\":\"${GAMES_DATADIR}/\":" \
+ src/locale_dialog.cpp || die
+ sed -i \
+ -e "/qm.path/s:\$\$PREFIX/share:${GAMES_DATADIR}:" \
+ ${PN}.pro || die
+}
+
+src_configure() {
+ eqmake4 BINDIR="${GAMES_BINDIR/\/usr}" PREFIX="/usr"
+}
+
+src_install() {
+ qt4-r2_src_install
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}