summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-07-29 12:55:07 -0500
committerAustin English <wizardedit@gentoo.org>2016-07-29 12:55:07 -0500
commit5d234dd26ba360a840e5f0a1adab777329ca8eac (patch)
treeef08b31e488469f6254e56b6f7bafda4f0ddfed0 /games-board/xmahjongg
parentdev-libs/leatherman: removing ruby20 (diff)
downloadgentoo-5d234dd26ba360a840e5f0a1adab777329ca8eac.tar.gz
gentoo-5d234dd26ba360a840e5f0a1adab777329ca8eac.tar.bz2
gentoo-5d234dd26ba360a840e5f0a1adab777329ca8eac.zip
games-board/xmahjongg: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-board/xmahjongg')
-rw-r--r--games-board/xmahjongg/xmahjongg-3.7-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-board/xmahjongg/xmahjongg-3.7-r1.ebuild b/games-board/xmahjongg/xmahjongg-3.7-r1.ebuild
new file mode 100644
index 000000000000..0bde35934015
--- /dev/null
+++ b/games-board/xmahjongg/xmahjongg-3.7-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="friendly GUI version of xmahjongg"
+HOMEPAGE="http://www.lcdf.org/xmahjongg/"
+SRC_URI="http://www.lcdf.org/xmahjongg/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-libs/libXt"
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/X_PRE_LIBS/s:-lSM -lICE::' \
+ configure || die
+}
+
+src_install() {
+ default
+ newicon share/tiles/small.gif ${PN}.gif
+ make_desktop_entry xmahjongg "Xmahjongg" /usr/share/pixmaps/${PN}.gif
+}