summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Pavlov <t.x00100x.t@yandex.ru>2023-12-08 15:59:39 +0300
committerUlrich Müller <ulm@gentoo.org>2023-12-26 23:49:27 +0100
commitf55cca15abceece466b1f4333774be0e4e55af82 (patch)
treed65fe28b14dd04cfda333d969e7880b8aaacaf21 /games-fps
parentgnome-base/gnome-session: drop old OpenOffice MIME type association entries (diff)
downloadgentoo-f55cca15abceece466b1f4333774be0e4e55af82.tar.gz
gentoo-f55cca15abceece466b1f4333774be0e4e55af82.tar.bz2
gentoo-f55cca15abceece466b1f4333774be0e4e55af82.zip
games-fps/serioussam-tfe-data: new package, add 1.5-r1
Bug: https://bugs.gentoo.org/854567 Signed-off-by: Alexander Pavlov <t.x00100x.t@yandex.ru> [Rename patch. Use ED instead of D.] Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/serioussam-tfe-data/Manifest1
-rw-r--r--games-fps/serioussam-tfe-data/metadata.xml15
-rw-r--r--games-fps/serioussam-tfe-data/serioussam-tfe-data-1.5-r1.ebuild70
3 files changed, 86 insertions, 0 deletions
diff --git a/games-fps/serioussam-tfe-data/Manifest b/games-fps/serioussam-tfe-data/Manifest
new file mode 100644
index 000000000000..925e2ce7d7a8
--- /dev/null
+++ b/games-fps/serioussam-tfe-data/Manifest
@@ -0,0 +1 @@
+DIST serioussam-Patch_1.05_FE.tar.xz 1221836 BLAKE2B 0ae7103151ee42f3c1ff88afd2d77037e0c3e5c49c19adf213068f87eed524c7aa6552d020c3337f5457847f167c1a2e4ca1fda7572e96b9630fb2dbfd3e6b0f SHA512 18c5a5f66e1fbe3864eca3274d20e525f50c223507e0c1c793a642aed66edfeb723cf3d4ffc583afa4d9a10388cbed14af7035bf6a1b9c214dac79c5eb1d2548
diff --git a/games-fps/serioussam-tfe-data/metadata.xml b/games-fps/serioussam-tfe-data/metadata.xml
new file mode 100644
index 000000000000..e76bc72b6a01
--- /dev/null
+++ b/games-fps/serioussam-tfe-data/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>t.x00100x.t@yandex.ru</email>
+ <name>Alexander Pavlov</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tx00100xt/serioussam-mods</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-fps/serioussam-tfe-data/serioussam-tfe-data-1.5-r1.ebuild b/games-fps/serioussam-tfe-data/serioussam-tfe-data-1.5-r1.ebuild
new file mode 100644
index 000000000000..3407e74c8e3b
--- /dev/null
+++ b/games-fps/serioussam-tfe-data/serioussam-tfe-data-1.5-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cdrom unpacker
+
+PATCH_PREFIX="Patch_1.05_FE"
+# Game name
+GN="serioussam"
+
+DESCRIPTION="Croteam's Serious Sam Classic The First Encounter ... the data files"
+HOMEPAGE="https://www.croteam.com/
+ https://store.steampowered.com/app/41050/Serious_Sam_Classic_The_First_Encounter/"
+SRC_URI="https://github.com/tx00100xt/serioussam-mods/raw/main/Patches/${PATCH_PREFIX}.tar.xz -> ${GN}-${PATCH_PREFIX}.tar.xz"
+S="${WORKDIR}"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist"
+
+pkg_setup() {
+ cdrom_get_cds "Install/1_00_music.gro"
+}
+
+src_unpack() {
+ mkdir Levels Mods || die "failed create dirs"
+ cat "${DISTDIR}/${GN}-${PATCH_PREFIX}.tar.xz" > "${PATCH_PREFIX}.tar.xz" \
+ || die "failed to copy patch 1.05"
+ unpack "${WORKDIR}/${PATCH_PREFIX}.tar.xz"
+}
+
+src_install() {
+ local dir="/usr/share/${GN}"
+
+ einfo "Copying from ${CDROM_ROOT}"
+ insinto "${dir}"
+ doins -r "${CDROM_ROOT}"/Install/*
+
+ mv "${WORKDIR}"/*.gro "${ED}${dir}" || die "failed to moved patch 1.05"
+ mv "${ED}${dir}"/Scripts/PersistentSymbols.ini "${WORKDIR}" \
+ || die "failed to moved PersistentSymbols.ini"
+
+ rm -rf \
+ "${ED}${dir}"/{Bin,Controls,Data,Demos,Mods,Players,Scripts} \
+ || die "failed to remove directories"
+ rm -rf \
+ "${ED}${dir}"/{VirtualTrees,Locales,Help/ShellSymbols.txt} \
+ || die "failed to remove directories"
+ mkdir "${ED}${dir}/Scripts" || die "failed create Scripts dir"
+ mv "${WORKDIR}"/PersistentSymbols.ini "${ED}${dir}/Scripts" \
+ || die "failed to moved PersistentSymbols.ini"
+
+ # Remove useless Windows files
+ rm -f "${ED}${dir}"/{*.exe,*.ex_,*.bmp,*.inx,*.hdr,*.bin,*.cab,*.ini,*.log} \
+ || die "Failed to remove windows cruft"
+
+ # Ensure that file datestamps from the CD are sane
+ find "${ED}${dir}"/Levels -exec touch -d '09 May 2020 14:00' '{}' \; \
+ || die "touch failed"
+}
+
+pkg_postinst() {
+ elog "Important information about the Linux port is at:"
+ elog " https://github.com/tx00100xt/SeriousSamClassic-VK"
+ elog " look at:"
+ elog " https://github.com/tx00100xt/SeriousSamClassic-VK/wiki"
+ elog " For information about of the game"
+}