summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-23 07:44:35 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-23 07:47:23 -0400
commit1e89835c72b0efd8523ea54d46dcb7e32e277b78 (patch)
treecccb177233db1c5cbfea73205c7d5b9eff43f8d8 /games-kids
parentgames-kids/gmult: drop vala workaround patch (diff)
downloadgentoo-1e89835c72b0efd8523ea54d46dcb7e32e277b78.tar.gz
gentoo-1e89835c72b0efd8523ea54d46dcb7e32e277b78.tar.bz2
gentoo-1e89835c72b0efd8523ea54d46dcb7e32e277b78.zip
games-kids/gmult: add 13.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/gmult/Manifest1
-rw-r--r--games-kids/gmult/gmult-13.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/games-kids/gmult/Manifest b/games-kids/gmult/Manifest
index 298e85c79718..1486fb7f3f25 100644
--- a/games-kids/gmult/Manifest
+++ b/games-kids/gmult/Manifest
@@ -1 +1,2 @@
DIST gmult-12.0.tar.bz2 195103 BLAKE2B d1d93190a607dc62bf4809dff7c5240c97f49dc4c833ea91028e9810961125eadba6fac41852b53f674b14c1e4c777a8d9ed58496ad2641ad99ed961041c40c8 SHA512 617b51defaf61c7967c9ccd6898209330733709df4290717e6c158719d04c61a38fa6832197c937f8aef1da23dc2f820c707291761ef8437ab0e78850253768c
+DIST gmult-13.0.tar.bz2 202650 BLAKE2B 894a7a5fda188497e4c3a431f40b1ccff6ab875e2938b8d4174fa8d1925087b921eca989a7678d9c99c8afc242c5ad741de0b88947a094da40469b6c1f803ac0 SHA512 08c162c6a7184d38044fd11f1bb04b50dd0ab763c60150bb3b706faff8b4ea360fd44c53bd41422e164593a869416a366927f9b90c923b372cf1f25b61b424a1
diff --git a/games-kids/gmult/gmult-13.0.ebuild b/games-kids/gmult/gmult-13.0.ebuild
new file mode 100644
index 000000000000..d30313af7d24
--- /dev/null
+++ b/games-kids/gmult/gmult-13.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson vala xdg
+
+DESCRIPTION="Multiplication Puzzle emulates the multiplication game found in Emacs"
+HOMEPAGE="https://gitlab.gnome.org/mterry/gmult/"
+SRC_URI="https://gitlab.gnome.org/mterry/gmult/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+ CC-BY-SA-4.0 CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # only used for unnecessary .desktop/.po validation
+
+RDEPEND="
+ dev-libs/glib:2
+ >=gui-libs/gtk-4.10:4[introspection]
+ >=gui-libs/libadwaita-1.3:1[vala]
+ virtual/libintl
+ x11-libs/cairo
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ sys-devel/gettext
+"
+
+DOCS=( NEWS.md README.md )
+
+src_configure() {
+ vala_setup
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}