summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-03-04 06:22:24 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-03-04 07:37:23 -0500
commitce38a532598651b348124b82fc5ac6a3e808daba (patch)
tree60d73109bd793b9b06c1f92b736b04a703e42675 /games-kids
parentnet-ftp/tnftp: Use system libedit (diff)
downloadgentoo-ce38a532598651b348124b82fc5ac6a3e808daba.tar.gz
gentoo-ce38a532598651b348124b82fc5ac6a3e808daba.tar.bz2
gentoo-ce38a532598651b348124b82fc5ac6a3e808daba.zip
games-kids/gmult: add 10.0, gtk3->4
Also EAPI7->8 and update LICENSE since upstream clarified usage. Upstream also made the check for appstream-glib/desktop-file-utils optional. Given only used by tests which aren't meaningful (e.g. runs desktop-file-validate on .desktop), removed and disabled tests rather than add IUSE=test. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/gmult/Manifest1
-rw-r--r--games-kids/gmult/gmult-10.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/games-kids/gmult/Manifest b/games-kids/gmult/Manifest
index 6f9d6b4900aa..6aeaa2c2d824 100644
--- a/games-kids/gmult/Manifest
+++ b/games-kids/gmult/Manifest
@@ -1 +1,2 @@
+DIST gmult-10.0.tar.xz 186116 BLAKE2B 0c3936983e1c6e72de7aa4056abdb1ec53af282d3927ca34a622d531966adc62e2e9c6740ab6c0cb3cfc9aedc21344c8866c5a2388498bd97c0faa3d32fae80b SHA512 f3eb639d4d6a67ca7d11595f0c4d4c2da613a95714f647536485fef4b64d277bf6f5bf163e363da691806b53ea885c56844287fe943fd521f995c7cce18b6a36
DIST gmult-9.0.tar.xz 47936 BLAKE2B ae0ebbebbdd949f7e990c6209c2ff695d34cf8e06a1e43fca137d9417b387fa58b1021f3bea5adace1832a39f60c5f2f77864ace888e4f1e70bed722951fd00e SHA512 b087406b1ea3743bc2ab292b9590a1d58451ca593d719b3539f22956304cd1004feed0fbf68c6a1bd0439f476c83f72287720d8937646ab214e6e50a4b04a27a
diff --git a/games-kids/gmult/gmult-10.0.ebuild b/games-kids/gmult/gmult-10.0.ebuild
new file mode 100644
index 000000000000..6df28b33de33
--- /dev/null
+++ b/games-kids/gmult/gmult-10.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson vala xdg
+
+DESCRIPTION="Multiplication Puzzle emulates the multiplication game found in Emacs"
+HOMEPAGE="https://launchpad.net/gmult/"
+SRC_URI="https://launchpad.net/gmult/trunk/${PV}/+download/${P}.tar.xz"
+
+LICENSE="GPL-3+ CC-BY-SA-4.0 CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # only used for unnecessary .desktop/.po validation
+
+RDEPEND="
+ dev-libs/glib:2
+ gui-libs/gtk:4[introspection]
+ gui-libs/libadwaita:1[vala]
+ virtual/libintl
+ x11-libs/cairo
+ x11-libs/pango"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ sys-devel/gettext"
+
+DOCS=( NEWS.md README.md )
+
+src_configure() {
+ vala_setup
+ meson_src_configure
+}