summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-20 02:42:16 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-20 03:01:04 -0400
commit5ccff9dd61c094d88ca5d0f41e8081d77b8533a1 (patch)
tree8215e0b2888ddeace044c72847c7e248170ec639 /games-puzzle
parentgames-emulation/pcsx2: add 1.7.5624 (diff)
downloadgentoo-5ccff9dd61c094d88ca5d0f41e8081d77b8533a1.tar.gz
gentoo-5ccff9dd61c094d88ca5d0f41e8081d77b8533a1.tar.bz2
gentoo-5ccff9dd61c094d88ca5d0f41e8081d77b8533a1.zip
games-puzzle/brainworkshop: add 5.0.3, enable py3.12
Note that this is 100% identical to the snapshot we we using for 5.0.2_p20230115 (not a single commit since), only difference is that it's officially released and we can use the tag. At same time, has no tests but py3.12 "seems" usable from quickly trying runtime. I say usable given it's not perfect, it startups more slowly and emits a warning, but beyond that it seems to run normally so think it's fine to add it. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/brainworkshop/Manifest1
-rw-r--r--games-puzzle/brainworkshop/brainworkshop-5.0.3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/games-puzzle/brainworkshop/Manifest b/games-puzzle/brainworkshop/Manifest
index 99431e04f0a3..e733bbc946d5 100644
--- a/games-puzzle/brainworkshop/Manifest
+++ b/games-puzzle/brainworkshop/Manifest
@@ -1 +1,2 @@
DIST brainworkshop-5.0.2_p20230115.tar.gz 8010699 BLAKE2B 9a3f443949ea56c15c65ba21a5df9dc0f06449eb14252d1f643e3f0fd507bbf52cd2001c63f549b0d475d4e17f56b4f5ec9d3d1235705b71bb5ec2f3aebdc85e SHA512 4aee26b0f92a14c362aa695f5325395fbef4517fc9fb6aeaa1c1d2d1123c60b574b8488c893204826bfd6194e4160c21be614b253004beb0626dc8ff7f23234b
+DIST brainworkshop-5.0.3.tar.gz 8005691 BLAKE2B 0edaf6edb2b33ccb09d3d76c7023257c26e7303237afe9c114315c3461f55e76944a2f1e24a3ed63f4b942e5ff816b776ea2561438996b5a286faeee016e9b42 SHA512 036ea1dff0d7346e9f34a889d306a160976a602200ba428e36e72eba1fb7fbd6a4d513811faf59dcf5efe8abeae26f0a882c295f845d88b5e9a7a59d1facad55
diff --git a/games-puzzle/brainworkshop/brainworkshop-5.0.3.ebuild b/games-puzzle/brainworkshop/brainworkshop-5.0.3.ebuild
new file mode 100644
index 000000000000..f7d1e7284064
--- /dev/null
+++ b/games-puzzle/brainworkshop/brainworkshop-5.0.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit desktop python-single-r1
+
+DESCRIPTION="Short-term-memory training N-Back game"
+HOMEPAGE="https://github.com/brain-workshop/brainworkshop/"
+SRC_URI="
+ https://github.com/brain-workshop/brainworkshop/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="CC-Sampling-Plus-1.0 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/pyglet[${PYTHON_USEDEP},sound]')
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.0.2-datadir.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i "s|@GENTOO_DATADIR@|${EPREFIX}/usr/share/${PN}|" ${PN}.py || die
+
+ python_fix_shebang ${PN}.py
+}
+
+src_install() {
+ newbin ${PN}.py ${PN}
+
+ insinto /usr/share/${PN}
+ doins -r res/.
+
+ dodoc Readme.md Readme-{instructions,resources}.txt data/Readme-stats.txt
+
+ domenu ${PN}.desktop
+ newicon res/misc/brain/brain.png ${PN}.png
+}