summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-12-09 22:28:51 +0000
committerJames Le Cuirot <chewi@gentoo.org>2020-12-09 22:28:51 +0000
commit00b02ef386304f480656e2e660a01192150cfc4a (patch)
tree4a1896c2dbfe9574b4dd84ca15fdbd661c8e62c7 /games-rpg/bastion
parentdev-lang/python-exec: Add USE=native-symlinks to break stuff (diff)
downloadgentoo-00b02ef386304f480656e2e660a01192150cfc4a.tar.gz
gentoo-00b02ef386304f480656e2e660a01192150cfc4a.tar.bz2
gentoo-00b02ef386304f480656e2e660a01192150cfc4a.zip
games-rpg/bastion: Bump to 20161016, drop old 20120620-r1
This version uses SDL2 rather than SDL1. Package-Manager: Portage-3.0.12, Repoman-3.0.1 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-rpg/bastion')
-rw-r--r--games-rpg/bastion/Manifest2
-rw-r--r--games-rpg/bastion/bastion-20120620-r1.ebuild84
-rw-r--r--games-rpg/bastion/bastion-20161016.ebuild67
3 files changed, 68 insertions, 85 deletions
diff --git a/games-rpg/bastion/Manifest b/games-rpg/bastion/Manifest
index 9f243c6c8d5f..9e98898b8f69 100644
--- a/games-rpg/bastion/Manifest
+++ b/games-rpg/bastion/Manifest
@@ -1 +1 @@
-DIST Bastion-HIB-2012-06-20.sh 1055161705 BLAKE2B 615ff88a3fab37aa70e60d1e692cb0b6a1e03dd90bf6294c65a134cbceb4d59675c341c4fca0b4e08ebda24007df727f09c31adfbe2f5f0e97d8e3b9010af4e1 SHA512 e81b5dfa6f61ec2b35b30693c156a612cd3242c2169f4414b6d66839b7d8cc2e6ea8776f55baae67fa8131ee96bc221e1a15004410612eecaa9f7204dcc673ad
+DIST bastion-10162016-bin 1080484945 BLAKE2B 0f755c54ff975afbb3ee087990849831fd405ddbe8ce83a062ba70d25ca6cbe69c9baf2535e8b1892fbbf4375830a3c7fe1ae7eb247d1ed3e46e2b10330270ca SHA512 108e181ad2a9a7eaedc84700f9399fd32d221259eea5200a41dfe21663cf6d3ac8ebd0c168095a7b9f6e71b953cc45203874bb4d32d319ee3547c99da924c8bc
diff --git a/games-rpg/bastion/bastion-20120620-r1.ebuild b/games-rpg/bastion/bastion-20120620-r1.ebuild
deleted file mode 100644
index e35826a5faa6..000000000000
--- a/games-rpg/bastion/bastion-20120620-r1.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils gnome2-utils check-reqs unpacker games
-
-TIMESTAMP=${PV:0:4}-${PV:4:2}-${PV:6:2}
-DESCRIPTION="An original action role-playing game set in a lush imaginative world"
-HOMEPAGE="https://supergiantgames.com/games/bastion/"
-SRC_URI="Bastion-HIB-${TIMESTAMP}.sh"
-
-LICENSE="all-rights-reserved"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-IUSE=""
-RESTRICT="bindist fetch splitdebug"
-
-MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
-QA_PREBUILT="${MYGAMEDIR#/}/Bastion.bin*
- ${MYGAMEDIR#/}/lib/*
- ${MYGAMEDIR#/}/lib64/*"
-
-# mono shit: vague dependencies
-RDEPEND="
- virtual/opengl
- media-libs/freealut
- media-libs/openal
- media-libs/sdl-gfx
- media-libs/sdl-image
- media-libs/sdl-mixer
- media-libs/sdl-net
- media-libs/sdl-ttf
- media-libs/smpeg
- x11-libs/libX11
- x11-libs/libXft"
-
-CHECKREQS_DISK_BUILD="2400M"
-
-pkg_nofetch() {
- einfo "Please buy & download ${SRC_URI} from:"
- einfo " ${HOMEPAGE}"
- einfo "and move it to your DISTDIR directory."
-}
-
-src_unpack() {
- myarch=$(usex amd64 "x86_64" "x86")
-
- unpack_makeself
-
- mv instarchive_all{,.tar.lzma} || die
- mv instarchive_linux_${myarch}{,.tar.lzma} || die
-
- mkdir ${P} || die
- cd ${P} || die
-
- unpack ./../instarchive_{all,linux_${myarch}}.tar.lzma
-}
-
-src_install() {
- insinto "${MYGAMEDIR}"
- doins -r *
-
- newicon -s 256 Bastion.png ${PN}.png
- make_desktop_entry ${PN}
- games_make_wrapper ${PN} "./Bastion.bin.${myarch}" "${MYGAMEDIR}" "${MYGAMEDIR}/$(get_libdir)"
-
- fperms +x "${MYGAMEDIR}"/Bastion.bin.${myarch}
- prepgamesdirs
-}
-
-pkg_preinst() {
- games_pkg_preinst
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- games_pkg_postinst
-
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}
diff --git a/games-rpg/bastion/bastion-20161016.ebuild b/games-rpg/bastion/bastion-20161016.ebuild
new file mode 100644
index 000000000000..d0388d065a8f
--- /dev/null
+++ b/games-rpg/bastion/bastion-20161016.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop check-reqs unpacker wrapper xdg
+
+TIMESTAMP=${PV:4:2}${PV:6:2}${PV:0:4}
+DESCRIPTION="An original action role-playing game set in a lush imaginative world"
+HOMEPAGE="https://supergiantgames.com/games/bastion/"
+SRC_URI="bastion-${TIMESTAMP}-bin"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR#/}/*"
+
+# Being a Mono-based game, it is tricky to determine the precise
+# dependencies. These were found by trial and error.
+RDEPEND="
+ media-libs/libsdl2[joystick,opengl,sound,video]
+ media-libs/libvorbis
+"
+BDEPEND="
+ app-arch/unzip
+"
+
+CHECKREQS_DISK_BUILD="2400M"
+S="${WORKDIR}/data"
+
+pkg_nofetch() {
+ einfo "Please buy and download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store/${PN}"
+ einfo "and move it to your distfiles directory."
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_prepare() {
+ default
+ rm -v lib*/libSDL2-2.0.so.0 || die
+}
+
+src_install() {
+ local \
+ arch=$(usex amd64 x86_64 x86) \
+ libdir=lib$(usex amd64 64 "")
+
+ insinto "${DIR}"
+ doins -r *.dll* Bastion.exe steam_appid.txt Content/ mono/
+
+ exeinto "${DIR}"
+ doexe Bastion.bin.${arch}
+
+ exeinto "${DIR}"/${libdir}
+ doexe ${libdir}/*.so*
+
+ dodoc Linux.README
+
+ make_wrapper ${PN} "env -u TERM \"${EPREFIX}${DIR}/Bastion.bin.${arch}\""
+ make_desktop_entry ${PN} Bastion applications-games
+}