summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-06 04:42:33 +0100
committerSam James <sam@gentoo.org>2021-04-06 19:18:29 +0100
commit386d736880b4b15be041f8a2fb737067942307b4 (patch)
tree8015ec7b38dad7f444b88d884f661dc256275190 /games-sports
parentgames-strategy/galaxyhack: port to EAPI 7, tidy up games.eclass remnants (diff)
downloadgentoo-386d736880b4b15be041f8a2fb737067942307b4.tar.gz
gentoo-386d736880b4b15be041f8a2fb737067942307b4.tar.bz2
gentoo-386d736880b4b15be041f8a2fb737067942307b4.zip
games-sports/billardgl: port to EAPI 7, eutils--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/billardgl/billardgl-1.75-r2.ebuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/games-sports/billardgl/billardgl-1.75-r2.ebuild b/games-sports/billardgl/billardgl-1.75-r2.ebuild
index 83ccabcbf9f2..5c1bcd616075 100644
--- a/games-sports/billardgl/billardgl-1.75-r2.ebuild
+++ b/games-sports/billardgl/billardgl-1.75-r2.ebuild
@@ -1,18 +1,19 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils
+EAPI=7
-DESCRIPTION="an OpenGL billards game"
+inherit desktop
+
+DESCRIPTION="An OpenGL billards game"
HOMEPAGE="https://sourceforge.net/projects/billardgl/"
SRC_URI="mirror://sourceforge/${PN}/BillardGL-${PV}.tar.gz
mirror://gentoo/${PN}.png"
+S="${WORKDIR}"/BillardGL-${PV}/src
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND="
media-libs/freeglut
@@ -22,34 +23,34 @@ DEPEND="
virtual/glu"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/BillardGL-${PV}/src
-
src_prepare() {
default
+
sed -i \
-e "s:/usr/share/BillardGL/:/usr/share/${PN}/:" \
- Namen.h \
- || die "sed Namen.h failed"
+ Namen.h || die "sed Namen.h failed"
+
sed -i \
-e '/^LINK/s:g++:$(CXX):' \
-e '/^CXX[[:space:]]/d' \
-e '/^CC[[:space:]]/d' \
-e '/^CXXFLAGS/s:=.*\(-D.*\)-.*:+=\1:' \
-e "/^LFLAGS/s:=:=${LDFLAGS}:" \
- Makefile \
- || die "sed Makefile failed"
+ Makefile || die "sed Makefile failed"
+
sed -i \
-e 's:<iostream.h>:<iostream>:' \
-e 's:<fstream.h>:<fstream>\nusing namespace std;:' \
- bmp.cpp \
- || die "sed bmp.cpp failed"
+ bmp.cpp || die "sed bmp.cpp failed"
}
src_install() {
newbin BillardGL ${PN}
+
insinto /usr/share/${PN}
doins -r lang Texturen
dodoc README
doicon "${DISTDIR}"/${PN}.png
+
make_desktop_entry ${PN} BillardGL
}