summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrettalcox <brettalcox@gmail.com>2024-02-24 08:14:15 -0600
committerYixun Lan <dlan@gentoo.org>2024-02-26 13:04:09 +0000
commitfd9f94f5973ae308d710493a830df56c248b1d66 (patch)
treea4b68bc807a78c4274265ea713610c27424a9d2d /gui-apps
parentapp-emulation/virtualbox-kvm: add 7.0.14_pre20240226 (diff)
downloadgentoo-fd9f94f5973ae308d710493a830df56c248b1d66.tar.gz
gentoo-fd9f94f5973ae308d710493a830df56c248b1d66.tar.bz2
gentoo-fd9f94f5973ae308d710493a830df56c248b1d66.zip
gui-apps/waybar: fix 9999 compile fail
requiring gtk-layer-shell in 9999 as it is now unconditionally required as a dependency. See https://github.com/Alexays/Waybar/pull/2836 Closes: https://bugs.gentoo.org/925017 Closes: https://github.com/gentoo/gentoo/pull/35514 Signed-off-by: brettalcox <brettalcox@gmail.com> Acked-by: Julien Roy <julien@jroy.ca> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/waybar/waybar-9999.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/gui-apps/waybar/waybar-9999.ebuild b/gui-apps/waybar/waybar-9999.ebuild
index bf1a1e03d3d5..9878369eda3e 100644
--- a/gui-apps/waybar/waybar-9999.ebuild
+++ b/gui-apps/waybar/waybar-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -19,7 +19,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="evdev experimental jack +libinput +logind mpd mpris network +popups pipewire pulseaudio sndio systemd test tray +udev upower wifi"
+IUSE="evdev experimental jack +libinput +logind mpd mpris network pipewire pulseaudio sndio systemd test tray +udev upower wifi"
REQUIRED_USE="
mpris? ( logind )
upower? ( logind )
@@ -44,6 +44,7 @@ RDEPEND="
>=dev-libs/spdlog-1.10.0:=
dev-libs/date:=
dev-libs/wayland
+ >=gui-libs/gtk-layer-shell-0.6.0:=
gui-libs/wlroots:=
x11-libs/gtk+:3[wayland]
x11-libs/libxkbcommon
@@ -57,7 +58,6 @@ RDEPEND="
mpd? ( media-libs/libmpdclient )
mpris? ( >=media-sound/playerctl-2 )
network? ( dev-libs/libnl:3 )
- popups? ( gui-libs/gtk-layer-shell )
pipewire? ( media-video/wireplumber:0/0.4 )
pulseaudio? ( media-libs/libpulse )
sndio? ( media-sound/sndio:= )
@@ -86,7 +86,6 @@ src_configure() {
$(meson_feature mpd)
$(meson_feature mpris)
$(meson_feature network libnl)
- $(meson_feature popups gtk-layer-shell)
$(meson_feature pulseaudio)
$(meson_feature pipewire wireplumber)
$(meson_feature sndio)