summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-11-12 11:59:50 -0500
committerYixun Lan <dlan@gentoo.org>2023-11-12 23:26:48 +0000
commit656d375c63e6022a688ea273ec3505ed187c4d10 (patch)
tree3b0bd0161db3df42ab7bb94c362f05115f5194dd /gui-wm/hyprland
parentdev-libs/kuserfeedback: pkgmove to kde-frameworks/kuserfeedback (diff)
downloadgentoo-656d375c63e6022a688ea273ec3505ed187c4d10.tar.gz
gentoo-656d375c63e6022a688ea273ec3505ed187c4d10.tar.bz2
gentoo-656d375c63e6022a688ea273ec3505ed187c4d10.zip
gui-wm/hyprland: add 0.32.3
Signed-off-by: Julien Roy <julien@jroy.ca> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'gui-wm/hyprland')
-rw-r--r--gui-wm/hyprland/Manifest1
-rw-r--r--gui-wm/hyprland/hyprland-0.32.3.ebuild130
2 files changed, 131 insertions, 0 deletions
diff --git a/gui-wm/hyprland/Manifest b/gui-wm/hyprland/Manifest
index eb0e7ab9c0fc..f129a887165c 100644
--- a/gui-wm/hyprland/Manifest
+++ b/gui-wm/hyprland/Manifest
@@ -1,3 +1,4 @@
DIST hyprland-0.31.0.gh.tar.gz 14068621 BLAKE2B 272ba0c92ee6f8db623bb7b79a64ec1a3f2d2e0e1a8825ab7cc43e30dc64d77396ae014469a308c10deea0f9607680ff3a9328b747c82acccd5156e9d9c07cde SHA512 27798eba3bc430fe3689ecfb6ae38a59f48c39183c8cbd4fea8dca0a92a25941e6ee8b51d70f18498a3b0ef6c2575658299ee36ed6a6a93c7b54548ab64f07ca
DIST hyprland-0.32.0.gh.tar.gz 14123937 BLAKE2B 3eb3c105681c22a1a4b2e38805a55015b741061977976f8e429068b79a59bfd6bac2ba74b2f547d81481cb404cad41bdec73eee67704bd11fddab3c213085a56 SHA512 293f0814530008f2f4561526aaca86a454de62bfae7ab508cf7ecdc12ec7029ba1fac2bb918cf0a2d4e8e9b423b463e5120591ebc8579489dcb7e07751d89ac9
DIST hyprland-0.32.2.gh.tar.gz 14119309 BLAKE2B 5a8924601d8db994532bbb7fc96962a9c8f9f11a52ee77c13c20cafc647617ba7eec2f4eea3672ba78decf5573b5a0394b73cb6041c2ea2f742e9557d14ff10b SHA512 6736c307bb29ddbfa46ed42b73c2cbe24bbf4b3a7113d370daba001dc1ace73f9e4174ad3e55e84b753fa57b42dccd618816408daa24eeef566b1bc70d729860
+DIST hyprland-0.32.3.gh.tar.gz 14119304 BLAKE2B 304878a3bb167da9ceae8afbde21bf2c64b81ffd61c13ccfd772f240d234bb9cbd448f7ae2d0fcc6d8e7c7e29e1eca66ad68d98cfef9b22caccae9ee9f3ae39d SHA512 521cfa6b3621142cb4cc1e6c11978e49f28b29836a1a8e00cc2c697f44dcf620da63e9d39deeabb41130a56c65464b6117416c8a3c1bd690bb056955b7ccea40
diff --git a/gui-wm/hyprland/hyprland-0.32.3.ebuild b/gui-wm/hyprland/hyprland-0.32.3.ebuild
new file mode 100644
index 000000000000..c77204ea1933
--- /dev/null
+++ b/gui-wm/hyprland/hyprland-0.32.3.ebuild
@@ -0,0 +1,130 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson toolchain-funcs
+
+DESCRIPTION="A dynamic tiling Wayland compositor that doesn't sacrifice on its looks"
+HOMEPAGE="https://github.com/hyprwm/Hyprland"
+
+SRC_URI="https://github.com/hyprwm/${PN^}/releases/download/v${PV}/source-v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-source"
+
+KEYWORDS="~amd64 ~riscv"
+LICENSE="BSD"
+SLOT="0"
+IUSE="X legacy-renderer systemd video_cards_nvidia"
+
+# bundled wlroots has the following dependency string according to included headers.
+# wlroots[drm,gles2-renderer,libinput,x11-backend?,X?]
+# enable x11-backend with X and vice versa
+WLROOTS_RDEPEND="
+ >=dev-libs/libinput-1.14.0:=
+ dev-libs/libliftoff
+ >=dev-libs/wayland-1.22
+ media-libs/libdisplay-info
+ media-libs/libglvnd
+ media-libs/mesa[egl(+),gles2]
+ sys-apps/hwdata:=
+ sys-auth/seatd:=
+ >=x11-libs/libdrm-2.4.114
+ x11-libs/libxkbcommon
+ >=x11-libs/pixman-0.42.0
+ virtual/libudev:=
+ X? (
+ x11-base/xwayland
+ x11-libs/libxcb:0=
+ x11-libs/xcb-util-renderutil
+ x11-libs/xcb-util-wm
+ )
+"
+WLROOTS_DEPEND="
+ >=dev-libs/wayland-protocols-1.32
+"
+WLROOTS_BDEPEND="
+ dev-util/glslang
+ dev-util/wayland-scanner
+"
+
+RDEPEND="
+ ${WLROOTS_RDEPEND}
+ dev-libs/glib:2
+ dev-libs/libinput
+ dev-libs/wayland
+ media-libs/libglvnd
+ x11-libs/cairo
+ x11-libs/libdrm
+ x11-libs/libxkbcommon
+ x11-libs/pango
+ x11-libs/pixman
+ X? (
+ x11-libs/libxcb:0=
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ ${WLROOTS_DEPEND}
+ dev-libs/hyprland-protocols
+ >=dev-libs/wayland-protocols-1.25
+"
+BDEPEND="
+ ${WLROOTS_BDEPEND}
+ || ( >=sys-devel/gcc-13:* >=sys-devel/clang-16:* )
+ app-misc/jq
+ dev-util/cmake
+ dev-util/wayland-scanner
+ dev-vcs/git
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} == binary ]] && return
+
+ if tc-is-gcc && ver_test $(gcc-version) -lt 13 ; then
+ eerror "Hyprland requires >=sys-devel/gcc-13 to build"
+ eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
+ die "GCC version is too old to compile Hyprland!"
+ elif tc-is-clang && ver_test $(clang-version) -lt 16 ; then
+ eerror "Hyprland requires >=sys-devel/clang-16 to build"
+ eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
+ die "Clang version is too old to compile Hyprland!"
+ fi
+}
+
+src_prepare() {
+ if use video_cards_nvidia; then
+ cd "${S}/subprojects/wlroots" || die
+ eapply "${S}/nix/patches/wlroots-nvidia.patch"
+ cd "${S}" || die
+ fi
+
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature legacy-renderer legacy_renderer)
+ $(meson_feature systemd)
+ $(meson_feature X xwayland)
+ $(meson_feature X wlroots:xwayland)
+ -Dwlroots:backends=drm,libinput$(usev X ',x11')
+ -Dwlroots:xcb-errors=disabled
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install --skip-subprojects wlroots
+ meson_src_install --tags devel
+
+ # Wlroots headers are required by hyprland-plugins and the pkgconfig file expects
+ # them to be in /usr/include/hyprland/wlroots, despite this they aren't installed there.
+ # Ideally you could override includedir per subproject and the install tags would
+ # be granular enough to only install headers. But its not requiring this.
+ mkdir "${ED}"/usr/include/hyprland/wlroots || die
+ mv "${ED}"/usr/include/wlr "${ED}"/usr/include/hyprland/wlroots || die
+ # devel tag includes wlroots .pc and .a files still
+ rm -rf "${ED}"/usr/$(get_libdir)/ || die
+}