summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-12-31 16:57:37 -0500
committerYixun Lan <dlan@gentoo.org>2024-01-02 12:06:35 +0000
commite303fa66ac1d3fb7581c20f05d70f004295383ef (patch)
treedbadc3e86929212fb3969e3464d4ec52b1ed5b17 /gui-wm/hyprland
parentnet-im/telegram-desktop: Hardcode XDG_DATA_DIRS variable (diff)
downloadgentoo-e303fa66ac1d3fb7581c20f05d70f004295383ef.tar.gz
gentoo-e303fa66ac1d3fb7581c20f05d70f004295383ef.tar.bz2
gentoo-e303fa66ac1d3fb7581c20f05d70f004295383ef.zip
gui-wm/hyprland: add patch for gcc14
Closes: https://bugs.gentoo.org/921123 Closes: https://github.com/gentoo/gentoo/pull/34588 Signed-off-by: Julien Roy <julien@jroy.ca> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'gui-wm/hyprland')
-rw-r--r--gui-wm/hyprland/files/gcc14.patch32
-rw-r--r--gui-wm/hyprland/hyprland-0.33.1.ebuild4
2 files changed, 36 insertions, 0 deletions
diff --git a/gui-wm/hyprland/files/gcc14.patch b/gui-wm/hyprland/files/gcc14.patch
new file mode 100644
index 000000000000..1bebe9e9d4c4
--- /dev/null
+++ b/gui-wm/hyprland/files/gcc14.patch
@@ -0,0 +1,32 @@
+# From: https://gitlab.freedesktop.org/wlroots/wlroots/-/commit/f3e1f7b2a70a500b740bfc406e893eba0852699a
+diff --git a/subprojects/wlroots/backend/libinput/tablet_pad.c b/subprojects/wlroots/backend/libinput/tablet_pad.c
+index 2e74022a..e5327528 100644
+--- a/subprojects/wlroots/backend/libinput/tablet_pad.c
++++ b/subprojects/wlroots/backend/libinput/tablet_pad.c
+@@ -33,7 +33,7 @@ static void add_pad_group_from_libinput(struct wlr_tablet_pad *pad,
+ ++group->ring_count;
+ }
+ }
+- group->rings = calloc(sizeof(unsigned int), group->ring_count);
++ group->rings = calloc(group->ring_count, sizeof(unsigned int));
+ if (group->rings == NULL) {
+ goto group_fail;
+ }
+@@ -50,7 +50,7 @@ static void add_pad_group_from_libinput(struct wlr_tablet_pad *pad,
+ ++group->strip_count;
+ }
+ }
+- group->strips = calloc(sizeof(unsigned int), group->strip_count);
++ group->strips = calloc(group->strip_count, sizeof(unsigned int));
+ if (group->strips == NULL) {
+ goto group_fail;
+ }
+@@ -66,7 +66,7 @@ static void add_pad_group_from_libinput(struct wlr_tablet_pad *pad,
+ ++group->button_count;
+ }
+ }
+- group->buttons = calloc(sizeof(unsigned int), group->button_count);
++ group->buttons = calloc(group->button_count, sizeof(unsigned int));
+ if (group->buttons == NULL) {
+ goto group_fail;
+ }
diff --git a/gui-wm/hyprland/hyprland-0.33.1.ebuild b/gui-wm/hyprland/hyprland-0.33.1.ebuild
index 049bd8915031..5c3cf3abef5f 100644
--- a/gui-wm/hyprland/hyprland-0.33.1.ebuild
+++ b/gui-wm/hyprland/hyprland-0.33.1.ebuild
@@ -77,6 +77,10 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}/gcc14.patch"
+)
+
pkg_setup() {
[[ ${MERGE_TYPE} == binary ]] && return