summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-05-13 21:54:56 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-05-13 22:12:56 +0200
commite5c6e6ca722ddc88b8575c976e024851645a3d3d (patch)
tree4614038a8ff7575a060cfefb43a4f7d88af18093 /kde-frameworks/frameworkintegration
parentprofiles: Mask KDE Frameworks 6.2.0 (diff)
downloadgentoo-e5c6e6ca722ddc88b8575c976e024851645a3d3d.tar.gz
gentoo-e5c6e6ca722ddc88b8575c976e024851645a3d3d.tar.bz2
gentoo-e5c6e6ca722ddc88b8575c976e024851645a3d3d.zip
kde-frameworks/frameworkintegration: 6.2.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-6.2.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index a96bf08863d4..91f4e1ac85a0 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.115.0.tar.xz 1760436 BLAKE2B 59127e732c3b1786e54a079315bf7d47b5025bd653348c67c167afdc2b6291ceb595d85f49c62cc080475fb0963851c07fd95aa2c344b8f0cc76610b701b5be8 SHA512 83cc9d4e1063cd1496dbe373f30f706dcb2ce2515735d7b82cd45cf35b20a8e6c51625b752c6e9a53033db1b0573f2f3159bd569becc707b3a2e7250ce7fd20a
DIST frameworkintegration-6.1.0.tar.xz 54792 BLAKE2B 7c9d9c0bee425d3d2719949daf7642785bb8fab714c590cc02f0e85638e20ee1c2f166f66271148e6f0f65ba21ed83b441305d3c4c32f6eeb42cd1feb4caabb2 SHA512 2f16528997b54ebb95e2fde1fe94133d672e72ef91bb2e607887b733fef128ea9c3e57b1f3f8cbf0ba74835dab6e145729725746918eaac98b643446a0cb3391
+DIST frameworkintegration-6.2.0.tar.xz 54812 BLAKE2B 09299a498a7d0c2367dbb491e66ea28b815a8665f5feb6548f288cc52481dcdba6841297afd192d352da79d68385fd6e4299ec9e42554b7035ca3b6f2d66e577 SHA512 cf1c3659e603bf52c4a45a5c7533022f5969900ced43725fbe0e86c47c278266b2d78cf86f7afcc69e912d4d85849a28c240d40b18379a6304a297928cabb3d9
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-6.2.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-6.2.0.ebuild
new file mode 100644
index 000000000000..e34dff31968e
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-6.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.2
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui,widgets]
+ =kde-frameworks/kcolorscheme-${PVCUT}*:6
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/ki18n-${PVCUT}*:6
+ =kde-frameworks/kiconthemes-${PVCUT}*:6
+ =kde-frameworks/knewstuff-${PVCUT}*:6
+ =kde-frameworks/knotifications-${PVCUT}*:6
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:6
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:6
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt6=ON
+ )
+
+ ecm_src_configure
+}