summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThamognya Kodi <contact@thamognya.com>2022-03-20 13:51:47 +0700
committerSam James <sam@gentoo.org>2022-03-22 00:27:03 +0000
commitcb4bc42b6ea69eacdcf3394448deaff32e91c1f2 (patch)
treedf3406dd65c117b41c02a52e8896baea5be284d9 /mail-client/alot
parentdev-lang/vala: Use SLOT="0.56" for 0.56.0. (diff)
downloadgentoo-cb4bc42b6ea69eacdcf3394448deaff32e91c1f2.tar.gz
gentoo-cb4bc42b6ea69eacdcf3394448deaff32e91c1f2.tar.bz2
gentoo-cb4bc42b6ea69eacdcf3394448deaff32e91c1f2.zip
mail-client/alot: add 0.10
Bug: https://bugs.gentoo.org/835592 Signed-off-by: Thamognya Kodi <contact@thamognya.com> Closes: https://github.com/gentoo/gentoo/pull/24680 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mail-client/alot')
-rw-r--r--mail-client/alot/Manifest1
-rw-r--r--mail-client/alot/alot-0.10.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/mail-client/alot/Manifest b/mail-client/alot/Manifest
index 7e7d59a08da6..7e4f08555174 100644
--- a/mail-client/alot/Manifest
+++ b/mail-client/alot/Manifest
@@ -1 +1,2 @@
DIST alot-0.9.1.tar.gz 228645 BLAKE2B 7a44542513bc6d90df43cb21daf2ba103cbbae4dd81b44eaf935d764ba11d6c5640774e72728725eca83a777dcf3583bebaa57c9061191499f74ed89d4c11b4f SHA512 ac65c742d5bfb4827482c881ec2eb95b9215e9a5c49d7001421d62ffb1f38c7792dbbf94c0f16578da70b5ce15ba7a28cea0c1bbd34080f8132c80f4a0a2199b
+DIST alot-0.10.tar.gz 228451 BLAKE2B a90672817d30a9dc5a50814b123f107f94cc63cb9669578c3ffa9f6282dc0388c91e1a7f14e62c73159573ff97660a57b71b5ecac6549e050758bcef60c54e87 SHA512 b07c77f3a21c9670fb14a760d036ce0e14678dd6ae75585cc929f97db5126a7dbb7f411244d317fea2913692afca6ff9f439f9dbbf047acffb8fcea2ebef7056
diff --git a/mail-client/alot/alot-0.10.ebuild b/mail-client/alot/alot-0.10.ebuild
new file mode 100644
index 000000000000..9f911d049abb
--- /dev/null
+++ b/mail-client/alot/alot-0.10.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Experimental terminal UI for net-mail/notmuch written in Python"
+HOMEPAGE="https://github.com/pazz/alot"
+SRC_URI="https://github.com/pazz/alot/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ app-crypt/gpgme[python,${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/urwidtrees[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ net-mail/mailbase
+ net-mail/notmuch[crypt,python,${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/0.9-0001-remove-non-working-test.patch"
+)
+
+distutils_enable_tests unittest
+
+python_compile_all() {
+ emake -C docs man
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ doman docs/build/man/*
+ distutils-r1_python_install_all
+
+ insinto /usr/share/alot
+ doins -r extra
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog ""
+ elog "If you are new to Alot you may want to take a look at"
+ elog "the user manual:"
+ elog " https://alot.readthedocs.io/en/latest/"
+ elog ""
+ fi
+}