summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrahmajit das <brahmajit.xyz@gmail.com>2022-07-03 00:20:28 +0530
committerSam James <sam@gentoo.org>2022-07-15 02:51:09 +0100
commit1bd3fa116f8bbf209550c8bfef2bc4ffd72ccc2e (patch)
tree234bcac581803be36a694121a8b5c2cc8cb2328b /mate-extra/mate-sensors-applet
parentapp-editors/pyvim: add 3.0.3 (diff)
downloadgentoo-1bd3fa116f8bbf209550c8bfef2bc4ffd72ccc2e.tar.gz
gentoo-1bd3fa116f8bbf209550c8bfef2bc4ffd72ccc2e.tar.bz2
gentoo-1bd3fa116f8bbf209550c8bfef2bc4ffd72ccc2e.zip
mate-extra/mate-sensors-applet: Removing unnecessary config checks
Removing unnecessary HAVE_STDIO_H and HAVE_LOCALE_H config checks. The HAVE_LOCALE_H also makes fails to build on musl system. Upstream issue: mate-desktop/mate-sensors-applet#123 Closes: https://bugs.gentoo.org/777375 Signed-off-by: brahmajit das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/26197 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mate-extra/mate-sensors-applet')
-rw-r--r--mate-extra/mate-sensors-applet/files/mate-sensors-applet-1.24.1-dont-check-for-headers.patch20
-rw-r--r--mate-extra/mate-sensors-applet/mate-sensors-applet-1.24.1.ebuild4
2 files changed, 24 insertions, 0 deletions
diff --git a/mate-extra/mate-sensors-applet/files/mate-sensors-applet-1.24.1-dont-check-for-headers.patch b/mate-extra/mate-sensors-applet/files/mate-sensors-applet-1.24.1-dont-check-for-headers.patch
new file mode 100644
index 000000000000..98aba2e903d5
--- /dev/null
+++ b/mate-extra/mate-sensors-applet/files/mate-sensors-applet-1.24.1-dont-check-for-headers.patch
@@ -0,0 +1,20 @@
+# Removing unnecessary HAVE_STDIO_H and HAVE_LOCALE_H config checks. The
+# HAVE_LOCALE_H also makes fails to build on musl system.
+# Upstream issue: https://github.com/mate-desktop/mate-sensors-applet/issues/123
+# Closes: https://bugs.gentoo.org/777375
+--- a/plugins/i2c-proc/i2c-proc-plugin.c
++++ b/plugins/i2c-proc/i2c-proc-plugin.c
+@@ -20,13 +20,8 @@
+ #include <config.h>
+ #endif /* HAVE_CONFIG_H */
+
+-#ifdef HAVE_STDIO_H
+ #include <stdio.h>
+-#endif /* HAVE_STDIO_H */
+-
+-#ifdef HAVE_LOCALE_H
+ #include <locale.h>
+-#endif
+
+ #include <glib.h>
+ #include <glib/gi18n.h>
diff --git a/mate-extra/mate-sensors-applet/mate-sensors-applet-1.24.1.ebuild b/mate-extra/mate-sensors-applet/mate-sensors-applet-1.24.1.ebuild
index c6264e8b1b34..fd9e54d09629 100644
--- a/mate-extra/mate-sensors-applet/mate-sensors-applet-1.24.1.ebuild
+++ b/mate-extra/mate-sensors-applet/mate-sensors-applet-1.24.1.ebuild
@@ -43,6 +43,10 @@ DEPEND="${COMMON_DEPEND}
PDEPEND="hddtemp? ( dbus? ( sys-fs/udisks:2 ) )"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.24.1-dont-check-for-headers.patch"
+)
+
src_configure() {
local udisks