summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-15 21:07:07 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-15 21:16:32 +0100
commit043e8de5728b09812035580454fd9b88123e7a06 (patch)
tree2f5e0de5934173306461da69c80b0e84eeae3bc2 /media-gfx
parentmedia-gfx/rawtherapee: Fix building with latest glibmm/libsigc++ (#568136) (diff)
downloadgentoo-043e8de5728b09812035580454fd9b88123e7a06.tar.gz
gentoo-043e8de5728b09812035580454fd9b88123e7a06.tar.bz2
gentoo-043e8de5728b09812035580454fd9b88123e7a06.zip
Revert "media-gfx/rawtherapee: Fix building with latest glibmm/libsigc++ (#568136)"
This reverts commit 519fe2b101ec4914e62246b72e9ba6139581e0c8.
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/rawtherapee/files/rawtherapee-4.2-cxx11.patch27
-rw-r--r--media-gfx/rawtherapee/rawtherapee-4.2.ebuild4
2 files changed, 0 insertions, 31 deletions
diff --git a/media-gfx/rawtherapee/files/rawtherapee-4.2-cxx11.patch b/media-gfx/rawtherapee/files/rawtherapee-4.2-cxx11.patch
deleted file mode 100644
index 48acb5fc6ffd..000000000000
--- a/media-gfx/rawtherapee/files/rawtherapee-4.2-cxx11.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 39ef59ddeb7679c71274b1da3faadd395b650c73 Mon Sep 17 00:00:00 2001
-From: Adam Reichold <adam.reichold@t-online.de>
-Date: Sun, 29 Nov 2015 11:48:30 +0100
-Subject: [PATCH] Build with '-std=c++11' if libsigc++ version 2.5.1 is used as
- it does require it.
-
----
- CMakeLists.txt | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index dd5fcbc..6153484 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -278,10 +278,10 @@ if (OPTION_OMP)
- endif (OPENMP_FOUND)
- endif (OPTION_OMP)
-
--if(USE_EXPERIMENTAL_LANG_VERSIONS)
-+if(USE_EXPERIMENTAL_LANG_VERSIONS OR NOT (SIGC_VERSION VERSION_LESS 2.5.1))
- SET (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu1x")
- SET (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=gnu++0x")
--endif (USE_EXPERIMENTAL_LANG_VERSIONS)
-+endif ()
-
- # find out whether we are building out of source
- get_filename_component(ABS_SOURCE_DIR "${PROJECT_SOURCE_DIR}" ABSOLUTE)
diff --git a/media-gfx/rawtherapee/rawtherapee-4.2.ebuild b/media-gfx/rawtherapee/rawtherapee-4.2.ebuild
index 6702661a6527..6ae07a579609 100644
--- a/media-gfx/rawtherapee/rawtherapee-4.2.ebuild
+++ b/media-gfx/rawtherapee/rawtherapee-4.2.ebuild
@@ -33,10 +33,6 @@ DEPEND="${RDEPEND}
app-arch/xz-utils
virtual/pkgconfig"
-PATCHES=(
- "${FILESDIR}"/${P}-cxx11.patch # Upstream patch for fixing bug #568136
-)
-
pkg_pretend() {
if use openmp ; then
tc-has-openmp || die "Please switch to an openmp compatible compiler"