summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2023-01-29 14:15:44 -0800
committerGöktürk Yüksek <gokturk@gentoo.org>2023-01-29 23:29:08 -0800
commit9ff05ce0ccdf53a239201eec51f4a0669397639d (patch)
tree3b16fe442b17a79b2fb059f38b1a22a65e4a9c93 /net-fs/davfs2
parentpackage.deprecated: Deprecate dev-python/python-distutils-extra (diff)
downloadgentoo-9ff05ce0ccdf53a239201eec51f4a0669397639d.tar.gz
gentoo-9ff05ce0ccdf53a239201eec51f4a0669397639d.tar.bz2
gentoo-9ff05ce0ccdf53a239201eec51f4a0669397639d.zip
net-fs/davfs2: add 1.7.0
Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'net-fs/davfs2')
-rw-r--r--net-fs/davfs2/Manifest1
-rw-r--r--net-fs/davfs2/davfs2-1.7.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/net-fs/davfs2/Manifest b/net-fs/davfs2/Manifest
index a00d16848aa2..996f227204d5 100644
--- a/net-fs/davfs2/Manifest
+++ b/net-fs/davfs2/Manifest
@@ -1,2 +1,3 @@
DIST davfs2-1.6.0.tar.gz 472511 BLAKE2B aed1ec060d5639fb90a58257038a75c25c2f77a7d6393130ffa3b4d36b92433654b8396dfe4615e4f2ea06d5c6d961d5de27b0347e62d730a22eddd003db71e1 SHA512 e016eb847152b7d0c20abfdafd36f43fcff29339362be6765202a45692a186c70b1c33d3566ed8ca695c399a7f0ca1aef7b05d378cdda33d892cb684da34de33
DIST davfs2-1.6.1.tar.gz 472426 BLAKE2B b24a3f17604838e763cbcf86f62719ee41b5569e58732441a621d210dd0c2e619d4f363d90e9b13d1616e84a3da940da941a15ad6eadfa2b339d14a6e26c75a2 SHA512 12f9eadd2049741b7cb61c5583be6c6982559e702e5cbd4767c655110187524d7afad0a6ff8ad00d457e194ad75b3ce391f5fe566fb4a0bbaed0a705caa3f163
+DIST davfs2-1.7.0.tar.gz 476244 BLAKE2B 671d473bc94c2a0cfc3d2cfb47b6eb558fee0e834ed4de9c3670279643f8903568d9fb077b6fbc2f81e848d076ff02ea5b07d885f16e89331393a28df62055a6 SHA512 6ee5820b60ed28ad100949bb4db65ea07bbae1ad0128cd35e7bb69f7f6bdde99606e8cf704ddb197f1400abadc3934d34ab85f298f9100b6ea9e60813c2345f2
diff --git a/net-fs/davfs2/davfs2-1.7.0.ebuild b/net-fs/davfs2/davfs2-1.7.0.ebuild
new file mode 100644
index 000000000000..21569512202b
--- /dev/null
+++ b/net-fs/davfs2/davfs2-1.7.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Linux FUSE (or coda) driver that allows you to mount a WebDAV resource"
+HOMEPAGE="https://savannah.nongnu.org/projects/davfs2"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="nls split-usr"
+RESTRICT="test"
+
+RDEPEND="dev-libs/libxml2
+ acct-group/davfs2
+ acct-user/davfs2
+ net-libs/neon:=
+ sys-libs/zlib
+ nls? ( virtual/libintl virtual/libiconv )
+"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ local f
+
+ # Let the package manager handle man page compression
+ while IFS="" read -d $'\0' -r f ; do
+ sed -e '/^manual[58]_DATA/ s/[.]gz//g' -i "${f}" || die
+ done < <(find "${S}"/man -type f -name 'Makefile.am' -print0)
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-largefile $(use_enable nls)
+}
+
+src_install() {
+ local ssbindir
+ if use split-usr; then
+ ssbindir=${EPREFIX}/sbin
+ else
+ ssbindir=${EPREFIX}/usr/sbin
+ fi
+
+ emake DESTDIR="${D}" sbindir="${ssbindir}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog
+ elog "Quick setup:"
+ elog " (as root)"
+ elog " # gpasswd -a \${your_user} davfs2"
+ elog " # echo 'https://path/to/dav /home/\${your_user}/dav davfs rw,user,noauto 0 0' >> /etc/fstab"
+ elog " (as user)"
+ elog " \$ mkdir -p ~/dav"
+ elog " \$ mount ~/dav"
+ elog
+}