summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2022-02-13 00:52:04 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2022-02-13 00:52:33 -0500
commitb00122a8df063438f19aec9474bad62f716d37c6 (patch)
tree4004100ec045a21667b4f1628844f6cdd0e6cc44 /net-fs/davfs2
parentdev-python/pip-run: Keyword 8.8.0 alpha, #832036 (diff)
downloadgentoo-b00122a8df063438f19aec9474bad62f716d37c6.tar.gz
gentoo-b00122a8df063438f19aec9474bad62f716d37c6.tar.bz2
gentoo-b00122a8df063438f19aec9474bad62f716d37c6.zip
net-fs/davfs2: bump to 1.6.1
Closes: https://bugs.gentoo.org/832195 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'net-fs/davfs2')
-rw-r--r--net-fs/davfs2/Manifest1
-rw-r--r--net-fs/davfs2/davfs2-1.6.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/net-fs/davfs2/Manifest b/net-fs/davfs2/Manifest
index a00b0ef6edd6..a00d16848aa2 100644
--- a/net-fs/davfs2/Manifest
+++ b/net-fs/davfs2/Manifest
@@ -1 +1,2 @@
DIST davfs2-1.6.0.tar.gz 472511 BLAKE2B aed1ec060d5639fb90a58257038a75c25c2f77a7d6393130ffa3b4d36b92433654b8396dfe4615e4f2ea06d5c6d961d5de27b0347e62d730a22eddd003db71e1 SHA512 e016eb847152b7d0c20abfdafd36f43fcff29339362be6765202a45692a186c70b1c33d3566ed8ca695c399a7f0ca1aef7b05d378cdda33d892cb684da34de33
+DIST davfs2-1.6.1.tar.gz 472426 BLAKE2B b24a3f17604838e763cbcf86f62719ee41b5569e58732441a621d210dd0c2e619d4f363d90e9b13d1616e84a3da940da941a15ad6eadfa2b339d14a6e26c75a2 SHA512 12f9eadd2049741b7cb61c5583be6c6982559e702e5cbd4767c655110187524d7afad0a6ff8ad00d457e194ad75b3ce391f5fe566fb4a0bbaed0a705caa3f163
diff --git a/net-fs/davfs2/davfs2-1.6.1.ebuild b/net-fs/davfs2/davfs2-1.6.1.ebuild
new file mode 100644
index 000000000000..a00ae2819d90
--- /dev/null
+++ b/net-fs/davfs2/davfs2-1.6.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Linux FUSE (or coda) driver that allows you to mount a WebDAV resource"
+HOMEPAGE="https://savannah.nongnu.org/projects/davfs2"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="nls"
+RESTRICT="test"
+
+RDEPEND="dev-libs/libxml2
+ acct-group/davfs2
+ acct-user/davfs2
+ net-libs/neon:=
+ sys-libs/zlib
+ nls? ( virtual/libintl virtual/libiconv )
+"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ local f
+
+ # Let the package manager handle man page compression
+ while IFS="" read -d $'\0' -r f ; do
+ sed -e '/^manual[58]_DATA/ s/[.]gz//g' -i "${f}" || die
+ done < <(find "${S}"/man -type f -name 'Makefile.am' -print0)
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-largefile $(use_enable nls)
+}
+
+pkg_postinst() {
+ elog
+ elog "Quick setup:"
+ elog " (as root)"
+ elog " # gpasswd -a \${your_user} davfs2"
+ elog " # echo 'https://path/to/dav /home/\${your_user}/dav davfs rw,user,noauto 0 0' >> /etc/fstab"
+ elog " (as user)"
+ elog " \$ mkdir -p ~/dav"
+ elog " \$ mount ~/dav"
+ elog
+}