summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2024-04-05 23:48:45 -0700
committerAmy Liffey <amynka@gentoo.org>2024-04-20 12:10:10 +0200
commitdea916b7acb979759a87c90ff23b147ebe7bec25 (patch)
treebe49e0c9c98186501e22f93854db301aabe13313 /net-fs/davfs2
parentnet-fs/davfs2: Restrict net-libs/neon dependency for stable version (diff)
downloadgentoo-dea916b7acb979759a87c90ff23b147ebe7bec25.tar.gz
gentoo-dea916b7acb979759a87c90ff23b147ebe7bec25.tar.bz2
gentoo-dea916b7acb979759a87c90ff23b147ebe7bec25.zip
net-fs/davfs2: Add net-libs/neon-0.33.0 support for testing versions
Add patch for build system and also add dependency slotting Closes: https://bugs.gentoo.org/925705 Closes: https://github.com/gentoo/gentoo/pull/36131 Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Signed-off-by: Gokturk Yuksek <gokturk@gentoo.org> Signed-off-by: Amy Liffey <amynka@gentoo.org>
Diffstat (limited to 'net-fs/davfs2')
-rw-r--r--net-fs/davfs2/davfs2-1.6.1-r3.ebuild (renamed from net-fs/davfs2/davfs2-1.6.1-r2.ebuild)8
-rw-r--r--net-fs/davfs2/davfs2-1.7.0-r1.ebuild (renamed from net-fs/davfs2/davfs2-1.7.0.ebuild)8
-rw-r--r--net-fs/davfs2/files/davfs2-1.6.1-neon-version-support.patch14
3 files changed, 26 insertions, 4 deletions
diff --git a/net-fs/davfs2/davfs2-1.6.1-r2.ebuild b/net-fs/davfs2/davfs2-1.6.1-r3.ebuild
index 27aa924e32d7..4685ec7210b8 100644
--- a/net-fs/davfs2/davfs2-1.6.1-r2.ebuild
+++ b/net-fs/davfs2/davfs2-1.6.1-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,7 +18,7 @@ RESTRICT="test"
RDEPEND="dev-libs/libxml2
acct-group/davfs2
acct-user/davfs2
- net-libs/neon:=
+ net-libs/neon:0/27
sys-libs/zlib
nls? ( virtual/libintl virtual/libiconv )
"
@@ -26,6 +26,10 @@ BDEPEND="
nls? ( sys-devel/gettext )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.1-neon-version-support.patch
+)
+
src_prepare() {
local f
diff --git a/net-fs/davfs2/davfs2-1.7.0.ebuild b/net-fs/davfs2/davfs2-1.7.0-r1.ebuild
index 3ac4673512f8..16f1eca17df8 100644
--- a/net-fs/davfs2/davfs2-1.7.0.ebuild
+++ b/net-fs/davfs2/davfs2-1.7.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,7 +18,7 @@ RESTRICT="test"
RDEPEND="dev-libs/libxml2
acct-group/davfs2
acct-user/davfs2
- net-libs/neon:=
+ net-libs/neon:0/27
sys-libs/zlib
nls? ( virtual/libintl virtual/libiconv )
"
@@ -26,6 +26,10 @@ BDEPEND="
nls? ( sys-devel/gettext )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.1-neon-version-support.patch
+)
+
src_prepare() {
local f
diff --git a/net-fs/davfs2/files/davfs2-1.6.1-neon-version-support.patch b/net-fs/davfs2/files/davfs2-1.6.1-neon-version-support.patch
new file mode 100644
index 000000000000..b002b49be6d3
--- /dev/null
+++ b/net-fs/davfs2/files/davfs2-1.6.1-neon-version-support.patch
@@ -0,0 +1,14 @@
+# Gentoo bug https://bugs.gentoo.org/925705
+
+diff -Naur davfs2-1.7.0-orig/configure.ac davfs2-1.7.0/configure.ac
+--- davfs2-1.7.0-orig/configure.ac 2022-09-08 13:17:15.000000000 -0700
++++ davfs2-1.7.0/configure.ac 2024-04-05 03:39:20.044039872 -0700
+@@ -36,7 +36,7 @@
+ # Checks for libraries.
+ AM_GNU_GETTEXT_VERSION(0.19.8)
+ AM_GNU_GETTEXT([external])
+-NE_REQUIRE_VERSIONS([0], [27 28 29 30 31 32])
++NE_REQUIRE_VERSIONS([0], [27 28 29 30 31 32 33])
+ DAV_CHECK_NEON
+
+ # Checks for header files.