summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2023-12-01 06:18:46 -0500
committerMike Frysinger <vapier@gentoo.org>2023-12-01 06:22:16 -0500
commit08eba8565709719f041022c35b828a9b7d5d1b70 (patch)
treeca69aacc49dcaee5917e9c87277f24d4e8a0d100 /net-nntp
parentdev-libs/mpfr: Stabilize 4.2.1 ppc, #914792 (diff)
downloadgentoo-08eba8565709719f041022c35b828a9b7d5d1b70.tar.gz
gentoo-08eba8565709719f041022c35b828a9b7d5d1b70.tar.bz2
gentoo-08eba8565709719f041022c35b828a9b7d5d1b70.zip
net-nntp/tin: fix build when $CPPFLAGS is set
The configure script defaults BUILD_CPPFLAGS to $CPPFLAGS, and if that is set, omits a required -I$srcdir/include flag from the build causing it to not find local tin.h headers. Append it ourselves. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/tin/tin-2.6.2-r1.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/net-nntp/tin/tin-2.6.2-r1.ebuild b/net-nntp/tin/tin-2.6.2-r1.ebuild
index c550f29e48bd..631a6ec8091d 100644
--- a/net-nntp/tin/tin-2.6.2-r1.ebuild
+++ b/net-nntp/tin/tin-2.6.2-r1.ebuild
@@ -52,6 +52,11 @@ src_configure() {
tc-export AR CC RANLIB
tc-export_build_env
+ # The build incorrectly discards its local -I if $CPPFLAGS is set.
+ if [[ -n ${BUILD_CPPFLAGS} ]]; then
+ BUILD_CPPFLAGS+=' -I$(INCDIR)'
+ fi
+
local myeconfargs=(
$(use_enable cancel-locks)
$(use_with cancel-locks canlock)