summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-09-15 21:20:56 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-09-15 22:06:47 +0200
commit9505d8612c2b4e400e333b49889ba16f850498e9 (patch)
tree9d34e2b7bf481e38cd8710243f577abda5c05caf /net-p2p/ktorrent
parentnet-news/alligator: 23.08.1 version bump (diff)
downloadgentoo-9505d8612c2b4e400e333b49889ba16f850498e9.tar.gz
gentoo-9505d8612c2b4e400e333b49889ba16f850498e9.tar.bz2
gentoo-9505d8612c2b4e400e333b49889ba16f850498e9.zip
net-p2p/ktorrent: 23.08.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-p2p/ktorrent')
-rw-r--r--net-p2p/ktorrent/Manifest1
-rw-r--r--net-p2p/ktorrent/files/ktorrent-23.08.1-cmake.patch50
-rw-r--r--net-p2p/ktorrent/ktorrent-23.08.1.ebuild97
3 files changed, 148 insertions, 0 deletions
diff --git a/net-p2p/ktorrent/Manifest b/net-p2p/ktorrent/Manifest
index fe2b27e0202a..0fdf671741e6 100644
--- a/net-p2p/ktorrent/Manifest
+++ b/net-p2p/ktorrent/Manifest
@@ -1,2 +1,3 @@
DIST ktorrent-23.04.3.tar.xz 2150912 BLAKE2B a5dd4db22d68098192d4a7d8e3b6f8ce60ffb46de46a007ed05548031db1e8a2e31e987fc36ea1a09186e27c08985319336ae5ba90c7127fe4c9035881fb357b SHA512 a803ed8963184f15029e034de4e6e25945d26bd3903afe838eaf0f0f74b3ccb53f1b7732694bda443b8d6bae5ca91f27622334fc628a41002eed7f8e3459c0e5
DIST ktorrent-23.08.0.tar.xz 2154144 BLAKE2B 1d8f701d4fe3d49ceeac08dee9074f59163be8b3b3573d1c73065b2b8d5a292d281752c8481c953cabb9818f2c942754dd6b552ff388e4dbb224c84b913c2055 SHA512 1c8ccb8492b2aa3ffec5d5dd35531770869e8d77bc78f6c5e247ed6e8e091a76ac19e188dbaaf70efcc8806de246143d3f53302f1494976fc264c585e37da196
+DIST ktorrent-23.08.1.tar.xz 2154312 BLAKE2B 614a4c19cebe29d27def7a04621570a2c7f2cff55381b4d286d375dbf9e0ca10723c9e78e54005a4b5242b9bb3adbdf091d056ab7938fdd60d2a4044bbbcb9ff SHA512 af209b84b246cc1cf5f08f85728bbaa4dfcaf299d7e2d4c14a65598d9cddfa01ae5518e794dceaf62f78bd1b8d106e2d6e837e827791a332641b4993454f2b32
diff --git a/net-p2p/ktorrent/files/ktorrent-23.08.1-cmake.patch b/net-p2p/ktorrent/files/ktorrent-23.08.1-cmake.patch
new file mode 100644
index 000000000000..5505092ccac1
--- /dev/null
+++ b/net-p2p/ktorrent/files/ktorrent-23.08.1-cmake.patch
@@ -0,0 +1,50 @@
+From 5d1dddb5322e19baf464f7aa82540eaf38bc88d0 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Thu, 14 Sep 2023 10:18:36 +0200
+Subject: [PATCH] Make KF5Archive required for ipfilter plugin
+
+Cleanup HAVE_KF5Archive var - it was unused since 023def08d07a4a3e346eef34e6142bf574435f6c,
+but we require libktorrent which has a hard requirement for KF5Archive anyway.
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 10 ----------
+ plugins/ipfilter/CMakeLists.txt | 2 ++
+ 2 files changed, 2 insertions(+), 10 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 07ad54d6..9010d632 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -83,16 +83,6 @@ if(KF5TextWidgets_FOUND)
+ set(HAVE_KF5TextWidgets 1)
+ endif()
+
+-find_package(KF5Archive ${KF5_MIN_VERSION})
+-set_package_properties(KF5Archive
+- PROPERTIES
+- TYPE OPTIONAL
+- PURPOSE "Required for KTorrent's scripting plugin"
+-)
+-if(KF5Archive_FOUND)
+- set(HAVE_KF5Archive 1)
+-endif()
+-
+ find_package(KF5ItemViews ${KF5_MIN_VERSION})
+ set_package_properties(KF5ItemViews
+ PROPERTIES
+diff --git a/plugins/ipfilter/CMakeLists.txt b/plugins/ipfilter/CMakeLists.txt
+index f59f251c..2a809a62 100644
+--- a/plugins/ipfilter/CMakeLists.txt
++++ b/plugins/ipfilter/CMakeLists.txt
+@@ -1,5 +1,7 @@
+ ktorrent_add_plugin(ktorrent_ipfilter)
+
++find_package(KF5Archive ${KF5_MIN_VERSION} REQUIRED)
++
+ target_sources(ktorrent_ipfilter PRIVATE
+ ipblocklist.cpp
+ ipblockingprefpage.cpp
+--
+2.42.0
+
diff --git a/net-p2p/ktorrent/ktorrent-23.08.1.ebuild b/net-p2p/ktorrent/ktorrent-23.08.1.ebuild
new file mode 100644
index 000000000000..df93a5e05e34
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-23.08.1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="optional"
+ECM_TEST="optional"
+KFMIN=5.106.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.9
+inherit ecm gear.kde.org
+
+DESCRIPTION="Powerful BitTorrent client based on KDE Frameworks"
+HOMEPAGE="https://apps.kde.org/ktorrent/"
+
+LICENSE="GPL-2"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="+bwscheduler +downloadorder +infowidget +ipfilter +logviewer +magnetgenerator
++mediaplayer rss +scanfolder +shutdown +stats +upnp +webengine +zeroconf"
+
+COMMON_DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/knotifyconfig-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ >=net-libs/libktorrent-${PVCUT}:5
+ infowidget? ( dev-libs/geoip )
+ ipfilter? ( >=kde-frameworks/karchive-${KFMIN}:5 )
+ mediaplayer? (
+ >=media-libs/phonon-4.11.0
+ >=media-libs/taglib-1.5
+ )
+ rss? (
+ >=dev-qt/qtwebengine-${QTMIN}:5
+ >=kde-frameworks/syndication-${KFMIN}:5
+ )
+ shutdown? ( kde-plasma/libkworkspace:5 )
+ stats? ( >=kde-frameworks/kplotting-${KFMIN}:5 )
+ upnp? ( >=kde-frameworks/kcompletion-${KFMIN}:5 )
+ webengine? ( >=dev-qt/qtwebengine-${QTMIN}:5 )
+ zeroconf? ( >=kde-frameworks/kdnssd-${KFMIN}:5 )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/boost-1.71
+"
+RDEPEND="${COMMON_DEPEND}
+ ipfilter? (
+ app-arch/bzip2
+ app-arch/unzip
+ kde-apps/kio-extras:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ )
+"
+BDEPEND="sys-devel/gettext"
+
+# TODO: https://invent.kde.org/network/ktorrent/-/merge_requests/76
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_BWSCHEDULER_PLUGIN=$(usex bwscheduler)
+ -DENABLE_DOWNLOADORDER_PLUGIN=$(usex downloadorder)
+ -DENABLE_INFOWIDGET_PLUGIN=$(usex infowidget)
+ -DENABLE_IPFILTER_PLUGIN=$(usex ipfilter)
+ -DENABLE_LOGVIEWER_PLUGIN=$(usex logviewer)
+ -DENABLE_MAGNETGENERATOR_PLUGIN=$(usex magnetgenerator)
+ -DENABLE_MEDIAPLAYER_PLUGIN=$(usex mediaplayer)
+ $(cmake_use_find_package rss KF5Syndication)
+ -DENABLE_SCANFOLDER_PLUGIN=$(usex scanfolder)
+ -DENABLE_SHUTDOWN_PLUGIN=$(usex shutdown)
+ -DENABLE_STATS_PLUGIN=$(usex stats)
+ -DENABLE_UPNP_PLUGIN=$(usex upnp)
+ -DENABLE_SEARCH_PLUGIN=$(usex webengine)
+ -DENABLE_ZEROCONF_PLUGIN=$(usex zeroconf)
+ )
+# add back when ported
+# -DENABLE_WEBINTERFACE_PLUGIN=$(usex webinterface)
+ ecm_src_configure
+}