summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2024-04-29 22:17:54 +0200
committerLouis Sautier <sbraz@gentoo.org>2024-04-29 22:19:09 +0200
commit18fde8f3dd6a9c2804afb2ceffdbff76eb9c5258 (patch)
tree589d5d9f927bf51de52e46705ce3a96cc733f66c /net-p2p
parentapp-admin/supervisor: re-add setuptools to RDEPEND, enable py312 (diff)
downloadgentoo-18fde8f3dd6a9c2804afb2ceffdbff76eb9c5258.tar.gz
gentoo-18fde8f3dd6a9c2804afb2ceffdbff76eb9c5258.tar.bz2
gentoo-18fde8f3dd6a9c2804afb2ceffdbff76eb9c5258.zip
net-p2p/torrentinfo: add 1.8.7, enable py312
Closes: https://bugs.gentoo.org/929737 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/torrentinfo/Manifest1
-rw-r--r--net-p2p/torrentinfo/torrentinfo-1.8.7.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/net-p2p/torrentinfo/Manifest b/net-p2p/torrentinfo/Manifest
index bc05406886b8..a39cce912e62 100644
--- a/net-p2p/torrentinfo/Manifest
+++ b/net-p2p/torrentinfo/Manifest
@@ -1 +1,2 @@
DIST torrentinfo-1.8.6.tar.gz 22232 BLAKE2B 04159e4e54fbe979a1a73e1dee39c9b7f9def389c44e3886fd28707646a2bc4c6a4dfadd5494ef9283427959da1c36260828693a0008e09993786d8639813bcf SHA512 7f36f6c80876cbd70ea9e1331195c8a30a6546406f345402d4bec5c58afb9b03a3b60189b8d177a63a7047c3ede7fc18d8fc47ecb1bcbb726dd01b7cb2a6efb2
+DIST torrentinfo-1.8.7.tar.gz 22325 BLAKE2B 07947a2b3b66b6bc25954f689bf8c070e75b6d0eca5f0f02900abfa9526f55aa9712b7c923fa4a5198050cbe83abb64ebc9154c4c32cb6b6cfb6b5b5bab104bd SHA512 751d4ca9d666058e768fee5c4469f9a76f6d1f6eb503271cf45d2c850f92cf0467723d94e8c6e5a78801be83aa3f83a30eb615b8a3dd7baa5bcc67e9a4544547
diff --git a/net-p2p/torrentinfo/torrentinfo-1.8.7.ebuild b/net-p2p/torrentinfo/torrentinfo-1.8.7.ebuild
new file mode 100644
index 000000000000..34117dc5b487
--- /dev/null
+++ b/net-p2p/torrentinfo/torrentinfo-1.8.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A torrent file parser"
+HOMEPAGE="https://github.com/Fuuzetsu/torrentinfo"
+SRC_URI="https://github.com/Fuuzetsu/torrentinfo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ # https://github.com/Fuuzetsu/torrentinfo/pull/16
+ "${FILESDIR}/${PN}-1.8.6-fix-tests.patch"
+ # https://github.com/Fuuzetsu/torrentinfo/pull/18
+ "${FILESDIR}/${PN}-1.8.6-remove-nose.patch"
+)
+
+distutils_enable_tests pytest