summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-print/cups-pdf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-print/cups-pdf')
-rw-r--r--net-print/cups-pdf/Manifest2
-rw-r--r--net-print/cups-pdf/cups-pdf-2.6.1.ebuild47
-rw-r--r--net-print/cups-pdf/cups-pdf-3.0_beta1.ebuild47
-rw-r--r--net-print/cups-pdf/metadata.xml5
4 files changed, 101 insertions, 0 deletions
diff --git a/net-print/cups-pdf/Manifest b/net-print/cups-pdf/Manifest
new file mode 100644
index 000000000000..99afba318b40
--- /dev/null
+++ b/net-print/cups-pdf/Manifest
@@ -0,0 +1,2 @@
+DIST cups-pdf_2.6.1.tar.gz 33315 SHA256 04e17eb563dceea048e1a435edcbcf52faa5288f85e8390cd64d702edb6745f1
+DIST cups-pdf_3.0beta1.tar.gz 38040 SHA256 d8f30740e0092e7b53cd228d9ddae8085bde744b5e63064bf79ad0c3e3ebe578 SHA512 89d77bf8daa4f82cde4db32c607a5d503ae37bc720906b9fafbd7dedac3cb522fbc342475cf4cff62fdbb16c59c7a1a62814cf85492f6a97e277e64c886985f5 WHIRLPOOL 6d44d4c62f198a4b8da83791bb22bad9e3a43dbcad2a587729e41eb80cd9a5cb14561dff522c6452cb591ad6463b14d9d0ff41b19e7c58db494db421d2446bf6
diff --git a/net-print/cups-pdf/cups-pdf-2.6.1.ebuild b/net-print/cups-pdf/cups-pdf-2.6.1.ebuild
new file mode 100644
index 000000000000..cb1182d1a307
--- /dev/null
+++ b/net-print/cups-pdf/cups-pdf-2.6.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Provides a virtual printer for CUPS to produce PDF files"
+HOMEPAGE="http://www.cups-pdf.de/"
+SRC_URI="http://www.cups-pdf.de/src/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="net-print/cups
+ app-text/ghostscript-gpl"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ cd "${S}"/src
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} ${PN}.c || die "Compilation failed."
+}
+
+src_install () {
+ exeinto /usr/libexec/cups/backend
+ exeopts -m0700
+ doexe src/cups-pdf
+
+ insinto /usr/share/cups/model
+ doins extra/CUPS-PDF.ppd
+
+ insinto /etc/cups
+ doins extra/cups-pdf.conf
+
+ dodoc ChangeLog README
+ newdoc contrib/Contents contrib_Contents
+}
+
+pkg_postinst () {
+ elog "Please view both the README and contrib_Contents files"
+ elog "as you may want to adjust some settings and/or use"
+ elog "contributed software. In the latter case you may need"
+ elog "to extract some files from the ${P} distfile."
+}
diff --git a/net-print/cups-pdf/cups-pdf-3.0_beta1.ebuild b/net-print/cups-pdf/cups-pdf-3.0_beta1.ebuild
new file mode 100644
index 000000000000..a8a3480706af
--- /dev/null
+++ b/net-print/cups-pdf/cups-pdf-3.0_beta1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="Provides a virtual printer for CUPS to produce PDF files"
+HOMEPAGE="http://www.cups-pdf.de/"
+SRC_URI="http://www.cups-pdf.de/src/${PN}_${PV/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="+ppds"
+
+RDEPEND="net-print/cups
+ app-text/ghostscript-gpl"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-${PV/_}
+
+src_compile() {
+ pushd src >/dev/null
+ $(tc-getCC) ${LDFLAGS} ${CFLAGS} ${PN}.c -o ${PN} -lcups || die
+ popd >/dev/null
+}
+
+src_install() {
+ exeinto /usr/libexec/cups/backend
+ exeopts -m0700
+ doexe src/cups-pdf
+
+ insinto /etc/cups
+ doins extra/cups-pdf.conf
+
+ insinto /usr/share/cups/model
+ if use ppds; then
+ doins extra/CUPS-PDF_opt.ppd
+ else
+ doins extra/CUPS-PDF_noopt.ppd
+ fi
+
+ dodoc ChangeLog README
+
+ dodoc -r contrib
+}
diff --git a/net-print/cups-pdf/metadata.xml b/net-print/cups-pdf/metadata.xml
new file mode 100644
index 000000000000..1fa0ca569505
--- /dev/null
+++ b/net-print/cups-pdf/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>printing</herd>
+</pkgmetadata>