summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-11-24 08:37:03 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-02-26 17:41:47 +0100
commita9e52949332e37aa92364987974051b1790e6635 (patch)
tree68950dd7f4489006af20e2d6e062e2e06e3a5884 /net-vpn
parentnet-vpn/eduvpn-client: add verify-sig support (diff)
downloadgentoo-a9e52949332e37aa92364987974051b1790e6635.tar.gz
gentoo-a9e52949332e37aa92364987974051b1790e6635.tar.bz2
gentoo-a9e52949332e37aa92364987974051b1790e6635.zip
net-vpn/eduvpn-client: add 9999
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/eduvpn-client/eduvpn-client-9999.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-vpn/eduvpn-client/eduvpn-client-9999.ebuild b/net-vpn/eduvpn-client/eduvpn-client-9999.ebuild
new file mode 100644
index 000000000000..6e6179988a41
--- /dev/null
+++ b/net-vpn/eduvpn-client/eduvpn-client-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="dev-python/mkdocs-material"
+DOCS_DIR="doc"
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 docs xdg-utils
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/eduvpn/python-${PN}.git"
+ S="${WORKDIR}/${P}"
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/eduvpn.asc
+ inherit verify-sig
+ MY_P="python-${P}"
+ SRC_URI="
+ https://github.com/eduvpn/python-eduvpn-client/releases/download/${PV}/${MY_P}.tar.xz
+ verify-sig? ( https://github.com/eduvpn/python-eduvpn-client/releases/download/${PV}/${MY_P}.tar.xz.asc )
+ "
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Linux client and Python client API for eduVPN"
+HOMEPAGE="https://www.eduvpn.org/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+# Test suite involves adding NetworkManager configuration entries,
+# disable for now.
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=net-vpn/eduvpn-common-1.2.0[${PYTHON_USEDEP}]
+"
+
+if [[ ${PV} != *9999* ]] ; then
+ BDEPEND="verify-sig? ( sec-keys/openpgp-keys-eduvpn )"
+fi
+
+PATCHES=(
+ "${FILESDIR}/${PN}-desktop.patch"
+)
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}