summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-01-03 11:35:10 -0600
committerWilliam Hubbs <williamh@gentoo.org>2024-01-03 11:35:33 -0600
commitd79727de547c72b5633c9a585f58e7cd1f88da10 (patch)
tree40c14c79d4f43246e60682443818dd1ea993483a /net-vpn
parentapp-crypt/johntheripper-jumbo: drop 1.9.0_p20211129-r1 (diff)
downloadgentoo-d79727de547c72b5633c9a585f58e7cd1f88da10.tar.gz
gentoo-d79727de547c72b5633c9a585f58e7cd1f88da10.tar.bz2
gentoo-d79727de547c72b5633c9a585f58e7cd1f88da10.zip
net-vpn/tailscale: add 1.56.1
Closes: https://bugs.gentoo.org/921176 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/tailscale/Manifest2
-rw-r--r--net-vpn/tailscale/tailscale-1.56.1.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/net-vpn/tailscale/Manifest b/net-vpn/tailscale/Manifest
index e276649c3319..d10568af0359 100644
--- a/net-vpn/tailscale/Manifest
+++ b/net-vpn/tailscale/Manifest
@@ -6,3 +6,5 @@ DIST tailscale-1.46.1-deps.tar.xz 370535596 BLAKE2B 84c37e83f6ced653132c9a3639ad
DIST tailscale-1.46.1.tar.gz 1817180 BLAKE2B b5ace1aa3fa98b14be53bbf55ec271cbbaf4c28a095300963961dd8bc5ee308091d46807af3b82f8ecb88070763a245292304706ab29e74d6f1e56ff495c2c51 SHA512 cecaa216b1f451b65e826856f630e5dd8ef9bbd85684602450e71f0f46b6b1b97bf20a0b7c401a72c354a5a9404386d6bd03350da2a65fb4e358320763d93ab4
DIST tailscale-1.50.1-deps.tar.xz 371484616 BLAKE2B cb4ac1939c4ad36bf3c752ccbdd1f34469e96e0576ae0f4bdede2f6e8ce8865c17addaead22c3be862846b1b9399900c0f3c8c0d720c5200c35405a974c85ec8 SHA512 3f11ba62e9879c0e51cd76a6e524d5e6bacb101e26e700872507f08c7924147a146a56933cd391a2b845bfb4fc7ad31a0a13dbc21dd3c8a2f7e10feea6d8b926
DIST tailscale-1.50.1.tar.gz 1992569 BLAKE2B 503dd358d13f038eafd67d2c00f292965eaba390ec483daded893082a87428c4bbf01bafb0339aaca3ebc62123985f0686046959d4aa25325b877a779de83b34 SHA512 3eb0e0f0ef6df4d77f9649fb8deb8b829286bc8ab70016b09da6aad9aa4e5d027494e2151db425b52e775997345d39d13bce6013e8c69700023a936f142dcfd6
+DIST tailscale-1.56.1-deps.tar.xz 395648828 BLAKE2B 08770560a70296af830763fdfd82ab16533911279c3d0719c5a628f8900292f1154b2a297111662152874251ae91081c03e34c25cb2016bd649bfcf89e423a3d SHA512 c3f91ce12ded8e0307e517f40c8953887ad4f85fe243d4dcfb7a874f478409dadc750e736c5d355a62dcacada30f1cf8f40adbc8d13ca9286f7456557da712ea
+DIST tailscale-1.56.1.tar.gz 2311243 BLAKE2B 3046aae1d6b652cd0ce56202b1f24bafca019621878e7da2258c2850b534d8dff713d4e32b4c985bc1636382505934efb320e751ca75275054139184b8e61640 SHA512 a6e213eeb885d160b816f7d795d8ae66cd322d652657ee5309e220c6526eb73d5aea07dcd57983468520891c5405fcb84255350cdacc078514cede8a351a4888
diff --git a/net-vpn/tailscale/tailscale-1.56.1.ebuild b/net-vpn/tailscale/tailscale-1.56.1.ebuild
new file mode 100644
index 000000000000..87e2fb6a8fad
--- /dev/null
+++ b/net-vpn/tailscale/tailscale-1.56.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# These settings are obtained by running ./build_dist.sh shellvars` in
+# the upstream repo.
+VERSION_MINOR="56"
+VERSION_SHORT="1.56.1"
+VERSION_LONG="1.56.1-tf1ea3161a"
+VERSION_GIT_HASH="f1ea3161a2a06ad6474a9ea919e91e9bd6062f84"
+
+DESCRIPTION="Tailscale vpn client"
+HOMEPAGE="https://tailscale.com"
+SRC_URI="https://github.com/tailscale/tailscale/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="net-firewall/iptables"
+BDEPEND=">=dev-lang/go-1.21"
+
+RESTRICT="test"
+
+# This translates the build command from upstream's build_dist.sh to an
+# ebuild equivalent.
+build_dist() {
+ ego build -tags xversion -ldflags "
+ -X tailscale.com/version.Long=${VERSION_LONG}
+ -X tailscale.com/version.Short=${VERSION_SHORT}
+ -X tailscale.com/version.GitCommit=${VERSION_GIT_HASH}" "$@"
+}
+
+src_compile() {
+ build_dist ./cmd/tailscale
+ build_dist ./cmd/tailscaled
+}
+
+src_install() {
+ dosbin tailscaled
+ dobin tailscale
+
+ systemd_dounit cmd/tailscaled/tailscaled.service
+ insinto /etc/default
+ newins cmd/tailscaled/tailscaled.defaults tailscaled
+ keepdir /var/lib/${PN}
+ fperms 0750 /var/lib/${PN}
+
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles" ${PN}.conf
+
+ newinitd "${FILESDIR}/${PN}d.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}d.confd" ${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}