summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2024-01-29 11:20:20 +0100
committerDavid Seifert <soap@gentoo.org>2024-01-29 11:20:20 +0100
commitda537eb5a80845bad2376524576fb7ec9e0bbfe3 (patch)
tree05ebd15bd16d1c31882650a382008241598ee560 /net-vpn
parentapp-backup/bareos: fix build (diff)
downloadgentoo-da537eb5a80845bad2376524576fb7ec9e0bbfe3.tar.gz
gentoo-da537eb5a80845bad2376524576fb7ec9e0bbfe3.tar.bz2
gentoo-da537eb5a80845bad2376524576fb7ec9e0bbfe3.zip
net-vpn/vpnc: add 0.5.3_p20240129
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/vpnc/Manifest1
-rw-r--r--net-vpn/vpnc/vpnc-0.5.3_p20240129.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/net-vpn/vpnc/Manifest b/net-vpn/vpnc/Manifest
index efc850dff590..48fcc5398dfa 100644
--- a/net-vpn/vpnc/Manifest
+++ b/net-vpn/vpnc/Manifest
@@ -1,2 +1,3 @@
DIST vpnc-0.5.3-docs.tar.xz 4816 BLAKE2B fe972fb71e74dea481593ce42225a2969608dd4d29a2f34ca1f7b5b82a71a62bfbd94d5fcd2e8db830768be1e858682904e655b8629cb164961644bc5de291e1 SHA512 e3e9f3e3651906f41a4a6b0f4247b903fb555155cbda210823f36a5613d8390b6aad7615ff88fd627ece4037b0e0f04753ac924c9cd9c1335480ca8186d476b8
DIST vpnc-0.5.3_p20220927.tar.gz 119773 BLAKE2B 0dabadac8b5a8116c07597140b6fa31e8f7daed9448e1bf653491809453ec114c0e96d38a8103d90a8b68dd2cefa0540ed676ced3fb9d57eaf16d8be5e3f0fa1 SHA512 e8c2254042c67283749331349467b2aed29ececc26de0bc3227c9c4a14f06d9d518599b28ca979df0cbe997c8997dda8afa508a0858c80ec270922096d8f906f
+DIST vpnc-0.5.3_p20240129.tar.gz 116840 BLAKE2B 3705bfe85cf5d7f0a9e07d58c71a305f951e5b1eabd8eb585e40732e867d06456f3f09d896679974f09a3eda019c9d449bde85f4976642db9c1a69e0efc9d476 SHA512 28fb6009e0efa38f19336ab95ae318906e9040c30120473acb8f1514fc9d2e3dc6aff58d7fc8af7e85a3ab5431f8234cb0afd3b1a2db84520fb6997b16221fff
diff --git a/net-vpn/vpnc/vpnc-0.5.3_p20240129.ebuild b/net-vpn/vpnc/vpnc-0.5.3_p20240129.ebuild
new file mode 100644
index 000000000000..c591b11be9a4
--- /dev/null
+++ b/net-vpn/vpnc/vpnc-0.5.3_p20240129.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info systemd toolchain-funcs
+
+DESCRIPTION="IPsec (Cisco/Juniper) VPN concentrator client"
+HOMEPAGE="https://github.com/streambinder/vpnc"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/streambinder/vpnc.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://api.github.com/repos/streambinder/vpnc/tarball/64468ff -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="resolvconf gnutls selinux"
+
+DEPEND="
+ dev-libs/libgcrypt:=
+ sys-apps/iproute2[-minimal]
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? ( dev-libs/openssl:= )"
+RDEPEND="${DEPEND}
+ >=net-vpn/vpnc-scripts-20210402-r1
+ resolvconf? ( virtual/resolvconf )
+ selinux? ( sec-policy/selinux-vpn )"
+BDEPEND="
+ dev-lang/perl
+ virtual/pkgconfig"
+
+CONFIG_CHECK="~TUN"
+
+src_unpack() {
+ if [[ ${PV} == *9999 ]]; then
+ git-r3_src_unpack
+ else
+ vcs-snapshot_src_unpack
+ fi
+}
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+ export OPENSSL_GPL_VIOLATION=$(usex !gnutls)
+}
+
+src_install() {
+ local args=(
+ PREFIX="${EPREFIX}"/usr
+ DOCDIR='$(PREFIX)'/share/doc/${PF}
+ SYSTEMDDIR="$(systemd_get_systemunitdir)"
+ DESTDIR="${D}"
+ )
+
+ emake "${args[@]}" install
+
+ keepdir /etc/vpnc/scripts.d
+ newinitd "${FILESDIR}"/vpnc-3.init vpnc
+ newconfd "${FILESDIR}"/vpnc.confd vpnc
+
+ # LICENSE file resides here, should not be installed
+ rm -r "${ED}"/usr/share/licenses || die
+}
+
+pkg_postinst() {
+ elog "You can generate a configuration file from the original Cisco profiles of your"
+ elog "connection by using /usr/bin/pcf2vpnc to convert the .pcf file"
+ elog "A guide is available at https://wiki.gentoo.org/wiki/Vpnc"
+}