summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/pilercr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/pilercr')
-rw-r--r--sci-biology/pilercr/Manifest1
-rw-r--r--sci-biology/pilercr/files/pilercr-1.0-gcc43.patch33
-rw-r--r--sci-biology/pilercr/metadata.xml5
-rw-r--r--sci-biology/pilercr/pilercr-1.0.ebuild31
4 files changed, 70 insertions, 0 deletions
diff --git a/sci-biology/pilercr/Manifest b/sci-biology/pilercr/Manifest
new file mode 100644
index 000000000000..b810410070ad
--- /dev/null
+++ b/sci-biology/pilercr/Manifest
@@ -0,0 +1 @@
+DIST pilercr-1.0.tar.gz 1709144 SHA256 75f58d58567c478e271c4c554071a7d6d642e6daef8981ee2618daa7b53fa923
diff --git a/sci-biology/pilercr/files/pilercr-1.0-gcc43.patch b/sci-biology/pilercr/files/pilercr-1.0-gcc43.patch
new file mode 100644
index 000000000000..7b49df872e27
--- /dev/null
+++ b/sci-biology/pilercr/files/pilercr-1.0-gcc43.patch
@@ -0,0 +1,33 @@
+diff -dur work/multaln.h work-orig/multaln.h
+--- work/multaln.h 2007-04-17 19:02:18.000000000 +0000
++++ work-orig/multaln.h 2009-02-18 21:25:26.166333299 +0000
+@@ -6,6 +6,7 @@
+ #define _CRT_SECURE_NO_DEPRECATE 1
+ #endif
+
++#include <cstring>
+ #include <vector>
+ #include <limits.h>
+ #include <ctype.h>
+diff -dur work/seqvect.h work-orig/seqvect.h
+--- work/seqvect.h 2006-04-06 23:36:18.000000000 +0000
++++ work-orig/seqvect.h 2009-02-18 21:25:26.171090246 +0000
+@@ -1,6 +1,7 @@
+ #ifndef SeqVect_h
+ #define SeqVect_h
+
++#include <stdio.h>
+ #include <vector>
+ #include "seq.h"
+
+diff -dur work/tree.h work-orig/tree.h
+--- work/tree.h 2006-04-05 23:52:42.000000000 +0000
++++ work-orig/tree.h 2009-02-18 21:25:26.171090246 +0000
+@@ -1,6 +1,7 @@
+ #ifndef tree_h
+ #define tree_h
+
++#include <stdlib.h>
+ #include <limits.h>
+
+ class Clust;
diff --git a/sci-biology/pilercr/metadata.xml b/sci-biology/pilercr/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/pilercr/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>
diff --git a/sci-biology/pilercr/pilercr-1.0.ebuild b/sci-biology/pilercr/pilercr-1.0.ebuild
new file mode 100644
index 000000000000..3241d42a863c
--- /dev/null
+++ b/sci-biology/pilercr/pilercr-1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Analysis of Clustered Regularly Interspaced Short Palindromic Repeats (CRISPRs)"
+HOMEPAGE="http://www.drive5.com/pilercr/"
+#SRC_URI="http://www.drive5.com/pilercr/pilercr.tar.gz"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
+src_compile() {
+ emake GPP="$(tc-getCXX)" CFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+}