summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-12 01:50:56 -0400
committerSam James <sam@gentoo.org>2024-03-12 06:14:20 +0000
commit224d5e9ecdba92cf4e9e7515056dcad158cbafbd (patch)
tree608c14dad35f4880090040580164b0fef3c3d3d0 /sci-biology
parentsci-libs/cgcode: filter LTO, no-SA (diff)
downloadgentoo-224d5e9ecdba92cf4e9e7515056dcad158cbafbd.tar.gz
gentoo-224d5e9ecdba92cf4e9e7515056dcad158cbafbd.tar.bz2
gentoo-224d5e9ecdba92cf4e9e7515056dcad158cbafbd.zip
sci-biology/glimmerhmm: patch sources to fix LTO
Upstream last released in 2015. I don't have high hopes for a change but I sent an email to the contact address. ;) Closes: https://bugs.gentoo.org/862270 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/glimmerhmm/files/0001-fix-ridiculous-ODR-violation.patch27
-rw-r--r--sci-biology/glimmerhmm/glimmerhmm-3.0.1-r1.ebuild3
2 files changed, 29 insertions, 1 deletions
diff --git a/sci-biology/glimmerhmm/files/0001-fix-ridiculous-ODR-violation.patch b/sci-biology/glimmerhmm/files/0001-fix-ridiculous-ODR-violation.patch
new file mode 100644
index 000000000000..58fa92819b59
--- /dev/null
+++ b/sci-biology/glimmerhmm/files/0001-fix-ridiculous-ODR-violation.patch
@@ -0,0 +1,27 @@
+From 282b1a113e002d8b90dedb6a5b6a6dc35e7310d1 Mon Sep 17 00:00:00 2001
+From: Eli Schwartz <eschwartz93@gmail.com>
+Date: Tue, 12 Mar 2024 01:45:16 -0400
+Subject: [PATCH] fix ridiculous ODR violation
+
+The return value of a function defined in another file is whatever that
+file defines, not "void because we didn't assign it to anything".
+---
+ sources/oc1.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/sources/oc1.h b/sources/oc1.h
+index 7b068c8..e28017d 100644
+--- a/sources/oc1.h
++++ b/sources/oc1.h
+@@ -49,7 +49,7 @@ struct tree_node
+ EDGE edge; /* used only in the display module. */
+ };
+
+-void error(char *);
++int error(char *);
+ void free_ivector(int *,int,int);
+ void free_vector(float *,int,int);
+ void free_dvector(double*,int,float);
+--
+2.43.2
+
diff --git a/sci-biology/glimmerhmm/glimmerhmm-3.0.1-r1.ebuild b/sci-biology/glimmerhmm/glimmerhmm-3.0.1-r1.ebuild
index b6fc54eb65b1..d118ce0996da 100644
--- a/sci-biology/glimmerhmm/glimmerhmm-3.0.1-r1.ebuild
+++ b/sci-biology/glimmerhmm/glimmerhmm-3.0.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,6 +20,7 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/${PV}-gentoo.patch
"${FILESDIR}"/${PN}-3.0.1-fix-data-path.patch
+ "${FILESDIR}"/0001-fix-ridiculous-ODR-violation.patch
)
src_configure() {