summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-04-21 10:54:14 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-04-21 11:26:53 +0300
commita29b90354124cbb1cd6aa12eed77303845cea348 (patch)
tree7e6aee3b00719f3daefa1debc35bc17b052a7645 /sci-calculators
parentsys-apps/flatpak: add 1.12.9, 1.14.6, security bump (diff)
downloadgentoo-a29b90354124cbb1cd6aa12eed77303845cea348.tar.gz
gentoo-a29b90354124cbb1cd6aa12eed77303845cea348.tar.bz2
gentoo-a29b90354124cbb1cd6aa12eed77303845cea348.zip
sci-calculators/units: add 2.23
Closes: https://bugs.gentoo.org/929996 Closes: https://bugs.gentoo.org/929755 Closes: https://bugs.gentoo.org/881639 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/units/Manifest1
-rw-r--r--sci-calculators/units/metadata.xml20
-rw-r--r--sci-calculators/units/units-2.23.ebuild59
3 files changed, 72 insertions, 8 deletions
diff --git a/sci-calculators/units/Manifest b/sci-calculators/units/Manifest
index 62a5de36de3f..2f123aa654f9 100644
--- a/sci-calculators/units/Manifest
+++ b/sci-calculators/units/Manifest
@@ -1 +1,2 @@
DIST units-2.21.tar.gz 1308533 BLAKE2B 0a02979eafa21af759128ec72b11e1f532640c9d0e88ae8f389a1beb52d5a400cbd6294042aa4c7d8786c06c8ac4106a77c302805b8c5e3bb84d4134805fd517 SHA512 34bacff606f12aa5b2e59170f6b2142277aa1121d79610a51b57f07f17ae2dbdfbbb0e60be34522f367679cc152408f77c1ebb551016224d23f81c21f4b3ba62
+DIST units-2.23.tar.gz 1423494 BLAKE2B 9a835ec3862b7c09149d5726084fb3068acb9d01b3a8234647cd47805a559b75131046bfe407152dec9f2e06c6c3315686dd0db0694d2c5ef0173e6ee64ce378 SHA512 628aac3a560ed728f1aba91841f9fccc0b145375a0b8953b98ac00c71bcc7f647377d16c6ba7b59e987a6e7a74b44038a62f2576f757a43d7564be469be81ee8
diff --git a/sci-calculators/units/metadata.xml b/sci-calculators/units/metadata.xml
index 0f742b8f2221..09b6ba2b5614 100644
--- a/sci-calculators/units/metadata.xml
+++ b/sci-calculators/units/metadata.xml
@@ -1,11 +1,15 @@
-<?xml version="1.0" encoding="UTF-8"?>
+<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <use>
- <flag name="units-cur">Install the units_cur python script that updates currencies</flag>
- </use>
- <upstream>
- <remote-id type="savannah">units</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>ceamac@gentoo.org</email>
+ <name>Viorel Munteanu</name>
+ </maintainer>
+ <use>
+ <flag name="units-cur">Install the units_cur python script that updates currencies</flag>
+ </use>
+ <upstream>
+ <remote-id type="savannah">units</remote-id>
+ <bugs-to>mailto:adrianm@gnu.org</bugs-to>
+ </upstream>
</pkgmetadata>
diff --git a/sci-calculators/units/units-2.23.ebuild b/sci-calculators/units/units-2.23.ebuild
new file mode 100644
index 000000000000..4d4fecb58392
--- /dev/null
+++ b/sci-calculators/units/units-2.23.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit python-r1
+
+DESCRIPTION="Unit conversion program"
+HOMEPAGE="https://www.gnu.org/software/units/units.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="FDL-1.3 GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+units-cur"
+REQUIRED_USE="units-cur? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ sys-libs/readline:=
+ units-cur? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/requests[${PYTHON_USEDEP}]
+ ')
+ )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.20-readerror.patch
+)
+
+DOCS=( NEWS README )
+
+src_configure() {
+ local myconf=(
+ --sharedstatedir="${EPREFIX}"/var/lib
+ ac_cv_path_PYTHON=no
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake ${PN}
+}
+
+src_install() {
+ default
+
+ if use units-cur; then
+ sed \
+ -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
+ -e 's|^#!|&/usr/bin/python|g' \
+ units_cur_inst > units_cur || die
+ python_foreach_impl python_doscript units_cur
+ fi
+}