summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2024-03-17 03:10:46 -0700
committerYixun Lan <dlan@gentoo.org>2024-03-17 22:54:13 +0000
commitc73c4847354fe809db380fd5676eb350ca1e36f4 (patch)
treea68858913620b9c7fd71698dc2fa5fa2c760923a /sci-electronics
parentsci-electronics/kicad: add 8.0.1 (diff)
downloadgentoo-c73c4847354fe809db380fd5676eb350ca1e36f4.tar.gz
gentoo-c73c4847354fe809db380fd5676eb350ca1e36f4.tar.bz2
gentoo-c73c4847354fe809db380fd5676eb350ca1e36f4.zip
sci-electronics/kicad-footprints: add 7.0.11
Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/kicad-footprints/Manifest1
-rw-r--r--sci-electronics/kicad-footprints/kicad-footprints-7.0.11.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/sci-electronics/kicad-footprints/Manifest b/sci-electronics/kicad-footprints/Manifest
index f44736c2f542..3a0244239bbd 100644
--- a/sci-electronics/kicad-footprints/Manifest
+++ b/sci-electronics/kicad-footprints/Manifest
@@ -1,3 +1,4 @@
DIST kicad-footprints-7.0.10.tar.bz2 24478270 BLAKE2B dd12467ba7bad3f0ab44164ea4ef6502f44143ec66173d5dadba62ab60559c0e75c4f77d00436ba2f7e1f0b527ae94cd0954fdd568031d049fbb69de56f13c0c SHA512 23fe7018f0f7328dc3d55e9f206d7ee4f4734be768d7024291b9d22c0134f1b887be5baf74fd601454e89a9a282aa9c0ad0ff631f5d29ec2ccac1c30b4dc1b66
+DIST kicad-footprints-7.0.11.tar.bz2 22722611 BLAKE2B f081eee0d8d2f9c691d7326dbc0a2edd329e027ae6602927f87e2e3c645fed1ba008e634a9043710ce552a94b01c28ac88461b83b97b26c225ad901af8535f21 SHA512 0786c08674432d797c7f98a05917ba22cfff4353e7b0e9007d61078cf6f5fc8ddf832e1a1e4d74788c9bf51fe9280ceae2c6051fce2253b5ba31b0a0f74d4511
DIST kicad-footprints-7.0.7.tar.bz2 24411508 BLAKE2B 1abedfbc3dfab302b5f929b01f2a83e83a4fee6b1d5056bf2c3579068c56807c656dea918f4c37fe030b727d3effbc35063f4f4103c4cfa6071f95c22d507597 SHA512 8af1fb371034bd5b22e0a8a896fa61e4eb0bda5b282759e17872bf4b466f49b39aa56ae068ac3d7d5a7453d9a7d511a81317d3f267a90d2764b2b8282f64aef0
DIST kicad-footprints-8.0.0.tar.bz2 26563192 BLAKE2B a575c3f7dc00ab14e6b7b9a52b56dfaa08c87aa4d53528fd59bfba3c5adf78e8ae98377cc3087db3dc6ae677046388f011062930ae07c427533b7254b99cbddd SHA512 6ad9863f3469523d48f5daf9b999177b0d6f43c347a390f3f55fcb8700f016c84c3513b1ee3e6f95112b1cadc3f7ee1c6c6f74b44d6b27aaa19f860d79e7e7de
diff --git a/sci-electronics/kicad-footprints/kicad-footprints-7.0.11.ebuild b/sci-electronics/kicad-footprints/kicad-footprints-7.0.11.ebuild
new file mode 100644
index 000000000000..60f7cdb4bc3f
--- /dev/null
+++ b/sci-electronics/kicad-footprints/kicad-footprints-7.0.11.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Electronic Schematic and PCB design tools footprint libraries"
+HOMEPAGE="https://gitlab.com/kicad/libraries/kicad-footprints"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.com/kicad/libraries/kicad-footprints.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.com/kicad/libraries/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="CC-BY-SA-4.0"
+SLOT="0"
+
+RDEPEND=">=sci-electronics/kicad-7.0.0"
+
+if [[ ${PV} == 9999 ]] ; then
+# x11-misc-util/macros only required on live ebuilds
+ BDEPEND+=" >=x11-misc/util-macros-1.18"
+fi