summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-15 02:52:06 -0400
committerSam James <sam@gentoo.org>2024-03-15 07:01:49 +0000
commit658f0410adfff5e7f92106bdc0a4458632d8ccce (patch)
tree78c0d05bfd7180f9f5bfcce7c9d109e0b4416594 /sci-geosciences
parentdev-lang/cfortran: filter LTO, no-SA (diff)
downloadgentoo-658f0410adfff5e7f92106bdc0a4458632d8ccce.tar.gz
gentoo-658f0410adfff5e7f92106bdc0a4458632d8ccce.tar.bz2
gentoo-658f0410adfff5e7f92106bdc0a4458632d8ccce.zip
sci-geosciences/laszip: mark as LTO-unsafe
Closes: https://bugs.gentoo.org/862582 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/laszip/laszip-3.4.1.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/sci-geosciences/laszip/laszip-3.4.1.ebuild b/sci-geosciences/laszip/laszip-3.4.1.ebuild
index 4c20bf887e69..fe87f91ea1c0 100644
--- a/sci-geosciences/laszip/laszip-3.4.1.ebuild
+++ b/sci-geosciences/laszip/laszip-3.4.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="Library for free and lossless compression of the LAS LiDAR format"
HOMEPAGE="https://laszip.org/"
@@ -14,3 +14,12 @@ LICENSE="LGPL-2.1+"
KEYWORDS="amd64 ~arm ~arm64 ~ppc ppc64 ~x86"
S="${WORKDIR}/${PN}-src-${PV}"
+
+src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/862582
+ # Fixed in newer version.
+ filter-lto
+
+ cmake_src_configure
+}