summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2022-03-27 14:29:52 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2022-03-27 14:30:32 +0200
commit2b6f5572eebaf357e41ac99d3f10e68c4f608c55 (patch)
tree062e52b3cf7fb85df7f636f71d7d556c9d49d47f /sci-libs/cartopy
parentnet-dns/bind-tools-9.16.27: fix build on Solaris (diff)
downloadgentoo-2b6f5572eebaf357e41ac99d3f10e68c4f608c55.tar.gz
gentoo-2b6f5572eebaf357e41ac99d3f10e68c4f608c55.tar.bz2
gentoo-2b6f5572eebaf357e41ac99d3f10e68c4f608c55.zip
sci-libs/cartopy: add 0.20.2
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'sci-libs/cartopy')
-rw-r--r--sci-libs/cartopy/Manifest1
-rw-r--r--sci-libs/cartopy/cartopy-0.20.2.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/sci-libs/cartopy/Manifest b/sci-libs/cartopy/Manifest
index 3bf117380669..e401f3bb438c 100644
--- a/sci-libs/cartopy/Manifest
+++ b/sci-libs/cartopy/Manifest
@@ -1,2 +1,3 @@
DIST cartopy-0.19.0.tar.gz 11738107 BLAKE2B 129a32850947e3439505812655b0feb25f33e3b45a909be56a0093cba41acbf777be7e899b528cc910e044fc8844438283eff4d20a1433ab5ea3c58f240efa0f SHA512 5019c752fed18295048cdbe927e28040b61327414262c67c079572969e8ec3abd76f4cb0e6dd1f8ee4cfb88426cbd926ff9a2e934e8d47b8a3180bf748bd7364
DIST cartopy-0.20.1.tar.gz 10704635 BLAKE2B 29ff571a4dccfe71585d6da4d11730fdb7d1b4bf28e9e16a7e928dc154a1fb74169fb122bf9dd2ebbc8b1a3d2ff4cd4591ec2afaa7eb9728ce1ae8a66facff1c SHA512 fe846fcaa8860f5bee4c478aa8a2125dad19d0d7988d10ee587590834728708f2a015104852d4320ba4d2367b78bad36cbdaa2b48cb6ed5b7b4d4e06a86e20d2
+DIST cartopy-0.20.2.tar.gz 10703222 BLAKE2B 18763971b33704c526bc98dede60077382de1e6855bd5dcc8901d729b9400eb2a3fdb2e6e2bd9b705ad2d43ab089e4837f12b7dc465429f1cdede21f174f8ef4 SHA512 1208c11a4b6d4b01b7ed7459ced7d79b0b60abc7be0f88562aa0d3826ac6bcebfe51cdf68213fd668353f4c269eb2c10fc2bf15e9db0b4c5802f629b76be3761
diff --git a/sci-libs/cartopy/cartopy-0.20.2.ebuild b/sci-libs/cartopy/cartopy-0.20.2.ebuild
new file mode 100644
index 000000000000..10493288f17e
--- /dev/null
+++ b/sci-libs/cartopy/cartopy-0.20.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1 virtualx
+
+MY_PV=${PV/_beta/b}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Python package for geospatial data processing and analysis"
+HOMEPAGE="https://scitools.org.uk/cartopy"
+SRC_URI="https://github.com/SciTools/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ sci-libs/geos
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/pyshp[${PYTHON_USEDEP}]
+ sci-libs/shapely[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/pillow[jpeg,${PYTHON_USEDEP}]
+ sci-libs/gdal[python,${PYTHON_USEDEP}]
+ dev-python/pyproj[${PYTHON_USEDEP}]
+ >=sci-libs/proj-8
+"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+DEPEND+="test? (
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/flufl-lock[$PYTHON_USEDEP]
+ )"
+
+S="${WORKDIR}"/${MY_P}
+
+python_prepare_all() {
+ # drop test file requiring network access, which got not covered by markers
+ rm "${S}"/lib/cartopy/tests/mpl/test_crs.py || die
+ rm "${S}"/lib/cartopy/tests/mpl/test_gridliner.py || die
+ # prepare matplotlib backend for test suite
+ export MPLCONFIGDIR="${T}"
+ echo "backend : Agg" > "${MPLCONFIGDIR}"/matplotlibrc || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}"
+ # drop all tests needing network access
+ virtx pytest -vv -m "not network and not natural_earth" || die "test failed"
+}