summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-04-25 23:04:59 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-25 23:04:59 +0300
commita65094f94199eaba21480880eef72451396cd328 (patch)
tree37ae69e0731ac159844e255fb5757d4706e4cfdd /sci-libs/libtifiles2
parentsci-libs/beagle: EAPI=8, cleanup, fix C++17 (diff)
downloadgentoo-a65094f94199eaba21480880eef72451396cd328.tar.gz
gentoo-a65094f94199eaba21480880eef72451396cd328.tar.bz2
gentoo-a65094f94199eaba21480880eef72451396cd328.zip
sci-libs/libtifiles2: EAPI 6 -> 8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sci-libs/libtifiles2')
-rw-r--r--sci-libs/libtifiles2/libtifiles2-1.1.7-r1.ebuild (renamed from sci-libs/libtifiles2/libtifiles2-1.1.7.ebuild)18
1 files changed, 10 insertions, 8 deletions
diff --git a/sci-libs/libtifiles2/libtifiles2-1.1.7.ebuild b/sci-libs/libtifiles2/libtifiles2-1.1.7-r1.ebuild
index 158a6d79c8b8..546127055cd2 100644
--- a/sci-libs/libtifiles2/libtifiles2-1.1.7.ebuild
+++ b/sci-libs/libtifiles2/libtifiles2-1.1.7-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
@@ -15,15 +15,17 @@ KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE="doc nls static-libs"
RDEPEND="
- app-arch/libarchive
+ app-arch/libarchive:=
dev-libs/glib:2
>=sci-libs/libticables2-1.3.3
>=sci-libs/libticonv-1.1.3
- nls? ( virtual/libintl )"
-
-DEPEND="${RDEPEND}
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
- nls? ( sys-devel/gettext )"
+ nls? ( sys-devel/gettext )
+"
DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
@@ -39,7 +41,7 @@ src_configure() {
}
src_install() {
- use doc && HTML_DOCS=( docs/html/. )
+ use doc && local HTML_DOCS=( docs/html/. )
default
find "${D}" -name '*.la' -delete || die
}