summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-04-14 17:35:48 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-04-14 17:56:09 +0200
commitf328869ac4fbc3d0f70cadf20b2d8fc393b9be34 (patch)
tree7687b67839ff538220fede25caa324c2711b8713 /sci-physics
parentsci-physics/lhapdf: fix egg install and force bash (diff)
downloadgentoo-f328869ac4fbc3d0f70cadf20b2d8fc393b9be34.tar.gz
gentoo-f328869ac4fbc3d0f70cadf20b2d8fc393b9be34.tar.bz2
gentoo-f328869ac4fbc3d0f70cadf20b2d8fc393b9be34.zip
sci-physics/lhapdf: use local -x to set CONFIG_SHELL
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de> Closes: https://github.com/gentoo/gentoo/pull/36247 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/lhapdf/lhapdf-6.3.0-r2.ebuild2
-rw-r--r--sci-physics/lhapdf/lhapdf-6.5.3-r1.ebuild2
-rw-r--r--sci-physics/lhapdf/lhapdf-6.5.4-r1.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/sci-physics/lhapdf/lhapdf-6.3.0-r2.ebuild b/sci-physics/lhapdf/lhapdf-6.3.0-r2.ebuild
index 01884ec1f0fe..acccf2facc60 100644
--- a/sci-physics/lhapdf/lhapdf-6.3.0-r2.ebuild
+++ b/sci-physics/lhapdf/lhapdf-6.3.0-r2.ebuild
@@ -52,7 +52,7 @@ src_prepare() {
}
src_configure() {
- CONFIG_SHELL="${EPREFIX}/bin/bash" \
+ local -x CONFIG_SHELL="${EPREFIX}/bin/bash"
econf \
--disable-static \
--enable-python
diff --git a/sci-physics/lhapdf/lhapdf-6.5.3-r1.ebuild b/sci-physics/lhapdf/lhapdf-6.5.3-r1.ebuild
index fff2f8d0b310..fc3184079097 100644
--- a/sci-physics/lhapdf/lhapdf-6.5.3-r1.ebuild
+++ b/sci-physics/lhapdf/lhapdf-6.5.3-r1.ebuild
@@ -36,7 +36,7 @@ PATCHES=(
)
src_configure() {
- CONFIG_SHELL="${EPREFIX}/bin/bash" \
+ local -x CONFIG_SHELL="${EPREFIX}/bin/bash"
econf \
--disable-static \
--enable-python
diff --git a/sci-physics/lhapdf/lhapdf-6.5.4-r1.ebuild b/sci-physics/lhapdf/lhapdf-6.5.4-r1.ebuild
index 7a306b01aeeb..7e3801a3d0e3 100644
--- a/sci-physics/lhapdf/lhapdf-6.5.4-r1.ebuild
+++ b/sci-physics/lhapdf/lhapdf-6.5.4-r1.ebuild
@@ -54,7 +54,7 @@ src_prepare() {
}
src_configure() {
- CONFIG_SHELL="${EPREFIX}/bin/bash" \
+ local -x CONFIG_SHELL="${EPREFIX}/bin/bash"
econf \
--disable-static \
$(use_enable python)