summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/biosdisk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/biosdisk')
-rw-r--r--sys-apps/biosdisk/Manifest1
-rw-r--r--sys-apps/biosdisk/biosdisk-0_p20100611-r1.ebuild46
-rw-r--r--sys-apps/biosdisk/metadata.xml14
3 files changed, 61 insertions, 0 deletions
diff --git a/sys-apps/biosdisk/Manifest b/sys-apps/biosdisk/Manifest
new file mode 100644
index 000000000000..6d5af87c3b72
--- /dev/null
+++ b/sys-apps/biosdisk/Manifest
@@ -0,0 +1 @@
+DIST biosdisk-git-06112010.tar.gz 1195889 SHA256 3319207abb6715ca032852190c64a2b27a227364f848eccd362ecdf1d3102478 SHA512 ade60e0e1ebb069e7f8d2046eff479cdb5186e54e0408b7fe65ac803476c9e325f9771617bbbcd60471d6b2d637aaef20c68af89c16c4ea26e04cfe501e4a310 WHIRLPOOL ca5340c25ab4a1eb579d180d404a0e4314500d85a309acdf36d0359d145b2266c76fcb446ff10212efb926034640e041e448bedf94a868a013a76dcdd4063cdc
diff --git a/sys-apps/biosdisk/biosdisk-0_p20100611-r1.ebuild b/sys-apps/biosdisk/biosdisk-0_p20100611-r1.ebuild
new file mode 100644
index 000000000000..39fd2880515d
--- /dev/null
+++ b/sys-apps/biosdisk/biosdisk-0_p20100611-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit versionator python-single-r1
+
+MY_PV=$(get_version_component_range 2)
+MY_PV_YEAR=${MY_PV:1:4}
+MY_PV_MONTH=${MY_PV:5:2}
+MY_PV_DAY=${MY_PV:7:2}
+MY_PV="${MY_PV_MONTH}${MY_PV_DAY}${MY_PV_YEAR}"
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="A script that creates floppy boot images to flash Dell BIOSes"
+HOMEPAGE="http://en.community.dell.com/techcenter/os-applications/w/wiki/linux-projects.aspx"
+SRC_URI="http://linux.dell.com/biosdisk/${PN}-git-${MY_PV}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="
+ >=app-text/dos2unix-5.0
+ sys-boot/syslinux
+ ${PYTHON_DEPS}
+"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_install() {
+ python_fix_shebang blconf
+
+ dosbin biosdisk blconf
+
+ dodoc AUTHORS README README.dosdisk TODO VERSION
+ doman biosdisk.8.gz
+
+ insinto /usr/share/biosdisk
+ doins dosdisk.img dosdisk{288,8192}.img biosdisk-mkrpm-{fedora,redhat,generic}-template.spec
+
+ insinto /etc
+ doins biosdisk.conf
+}
diff --git a/sys-apps/biosdisk/metadata.xml b/sys-apps/biosdisk/metadata.xml
new file mode 100644
index 000000000000..b61e26392d00
--- /dev/null
+++ b/sys-apps/biosdisk/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>mattsch@gmail.com</email>
+ <name>Matthew Schultz</name>
+ <description>Assign bugs to him</description>
+</maintainer>
+<maintainer>
+ <email>pacho@gentoo.org</email>
+ <description>Proxy maintainer, CC him in bugs</description>
+</maintainer>
+</pkgmetadata>