summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-06-24 22:28:24 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-06-24 22:28:44 +0200
commita080e02f38f5641870074b3682d5d0d4722f321e (patch)
tree0a7d271b0d9e18cf3710a5280746e080c1fa3ef4 /sys-apps/biosdisk
parentsys-apps/biosdisk: drop to m-n (diff)
downloadgentoo-a080e02f38f5641870074b3682d5d0d4722f321e.tar.gz
gentoo-a080e02f38f5641870074b3682d5d0d4722f321e.tar.bz2
gentoo-a080e02f38f5641870074b3682d5d0d4722f321e.zip
sys-apps/biosdisk: bump to version 1.01
Closes: https://bugs.gentoo.org/696194 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps/biosdisk')
-rw-r--r--sys-apps/biosdisk/Manifest1
-rw-r--r--sys-apps/biosdisk/biosdisk-1.01.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/biosdisk/Manifest b/sys-apps/biosdisk/Manifest
index ecfc5412c4ee..2dca2afd174f 100644
--- a/sys-apps/biosdisk/Manifest
+++ b/sys-apps/biosdisk/Manifest
@@ -1 +1,2 @@
DIST biosdisk-0_p20171116.tar.gz 712587 BLAKE2B f09a8c68f57cddb1949d369cfc18d1216c3e64612a7074c58e6c50c12682fce92a4d6295810d5358fac0340483387f14059811a5681ae4f37c7da8e40c34fec4 SHA512 27d99990d0e92f1295d2ddb949214946db681e7f80c6606b252473fe7b5b0d3254180b54cb26479c9014219f6b989aa6ba29e8a818f3801f9ccce4efd2f1c3b9
+DIST biosdisk-1.01.tar.gz 214715 BLAKE2B 1a42523d0ec713a895276e3ca3b383206bb841c59bf789eb2b869ce3ade6bfde1e96d47afb8874eec5efec1ef4d404c093a707e36d2d9ab785211fa62abb5782 SHA512 f1920a0eee0a1f8530488c5ccd3f37b36170150b7658658af55beb41c2084c66b6d6bded6e144e36dd9d74f963881c504d7869bbe5c8b57749bff4d918581537
diff --git a/sys-apps/biosdisk/biosdisk-1.01.ebuild b/sys-apps/biosdisk/biosdisk-1.01.ebuild
new file mode 100644
index 000000000000..f4ae904c895e
--- /dev/null
+++ b/sys-apps/biosdisk/biosdisk-1.01.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="FreeDOS based BIOS updating utility for Dell machines"
+HOMEPAGE="https://github.com/dell/biosdisk"
+SRC_URI="https://github.com/dell/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-cdr/cdrtools
+ sys-boot/grub
+ sys-boot/syslinux
+"
+
+src_prepare() {
+ default
+
+ sed -e 's/biosdisk.8.gz/biosdisk.8/g' -e '/gzip/d' -i Makefile || die
+}
+
+src_install() {
+ default
+
+ keepdir /var/lib/biosdisk
+}