summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-04-27 18:38:59 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-04-27 23:45:13 +0200
commit6a5d15b5f4e8a67bfc752d79ac5676302a9352c9 (patch)
treee602b6567dce75d0a9e26282d6ab065176a1ebe1 /sys-apps/chname
parentwww-servers/puma: remove unused patch(es) (diff)
downloadgentoo-6a5d15b5f4e8a67bfc752d79ac5676302a9352c9.tar.gz
gentoo-6a5d15b5f4e8a67bfc752d79ac5676302a9352c9.tar.bz2
gentoo-6a5d15b5f4e8a67bfc752d79ac5676302a9352c9.zip
sys-apps/chname: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/30778 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps/chname')
-rw-r--r--sys-apps/chname/chname-1.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/chname/chname-1.1-r1.ebuild b/sys-apps/chname/chname-1.1-r1.ebuild
new file mode 100644
index 000000000000..c7d8a16b1961
--- /dev/null
+++ b/sys-apps/chname/chname-1.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Run a command with a new system hostname"
+HOMEPAGE="https://github.com/marineam/chname"
+SRC_URI="https://github.com/marineam/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=sys-kernel/linux-headers-2.6.16"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-flags.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ dodoc README*
+}