summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-07 02:50:27 +0100
committerSam James <sam@gentoo.org>2023-06-07 02:50:27 +0100
commit8d4d6bd4de28a5f9efc783d947397dabe7ffd568 (patch)
treef7095dabbc32917eaff0fea2a841d5929ae51368 /sys-apps/dtc
parentapp-text/texlive-core: stable 2021-r7 for hppa, bug #907240 (diff)
downloadgentoo-8d4d6bd4de28a5f9efc783d947397dabe7ffd568.tar.gz
gentoo-8d4d6bd4de28a5f9efc783d947397dabe7ffd568.tar.bz2
gentoo-8d4d6bd4de28a5f9efc783d947397dabe7ffd568.zip
sys-apps/dtc: set SETUPTOOLS_SCM_PRETEND_VERSION
I test with a git repo in WORKDIR so I didn't hit this myself before. Bug: https://bugs.gentoo.org/835733 Closes: https://bugs.gentoo.org/907960 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/dtc')
-rw-r--r--sys-apps/dtc/dtc-1.7.0.ebuild5
-rw-r--r--sys-apps/dtc/dtc-9999.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/sys-apps/dtc/dtc-1.7.0.ebuild b/sys-apps/dtc/dtc-1.7.0.ebuild
index 6427393029fc..a56040b060aa 100644
--- a/sys-apps/dtc/dtc-1.7.0.ebuild
+++ b/sys-apps/dtc/dtc-1.7.0.ebuild
@@ -47,7 +47,10 @@ PATCHES=(
)
pkg_setup() {
- use python && python-single-r1_pkg_setup
+ if use python ; then
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+ python-single-r1_pkg_setup
+ fi
}
src_prepare() {
diff --git a/sys-apps/dtc/dtc-9999.ebuild b/sys-apps/dtc/dtc-9999.ebuild
index 72cf9d539b46..ef30384edbe0 100644
--- a/sys-apps/dtc/dtc-9999.ebuild
+++ b/sys-apps/dtc/dtc-9999.ebuild
@@ -42,7 +42,10 @@ DOCS=(
)
pkg_setup() {
- use python && python-single-r1_pkg_setup
+ if use python ; then
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+ python-single-r1_pkg_setup
+ fi
}
src_prepare() {