summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-07-07 08:18:51 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-07-07 08:18:51 +0100
commitf593ae21fe4e8f4f2e92a4c3a802e2f8e9baefb7 (patch)
treea6a67ca6da413a1913b536d0aff32e2be6a1cf9a /sys-apps/dtc
parentsys-apps/dtc: bump up to 1.6.0 (diff)
downloadgentoo-f593ae21fe4e8f4f2e92a4c3a802e2f8e9baefb7.tar.gz
gentoo-f593ae21fe4e8f4f2e92a4c3a802e2f8e9baefb7.tar.bz2
gentoo-f593ae21fe4e8f4f2e92a4c3a802e2f8e9baefb7.zip
sys-apps/dtc: drop old
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-apps/dtc')
-rw-r--r--sys-apps/dtc/dtc-1.5.0-r1.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/sys-apps/dtc/dtc-1.5.0-r1.ebuild b/sys-apps/dtc/dtc-1.5.0-r1.ebuild
deleted file mode 100644
index 466cd72eb844..000000000000
--- a/sys-apps/dtc/dtc-1.5.0-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit multilib toolchain-funcs eutils
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/dtc/dtc.git"
- inherit git-r3
-else
- SRC_URI="https://www.kernel.org/pub/software/utils/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-fi
-
-DESCRIPTION="Open Firmware device tree compiler"
-HOMEPAGE="https://devicetree.org/ https://git.kernel.org/cgit/utils/dtc/dtc.git/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="static-libs yaml"
-
-BDEPEND="
- sys-devel/bison
- sys-devel/flex
- virtual/pkgconfig
-"
-RDEPEND="yaml? ( dev-libs/libyaml )"
-DEPEND="${RDEPEND}"
-
-DOCS="
- Documentation/dt-object-internal.txt
- Documentation/dts-format.txt
- Documentation/manual.txt
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.4.4-posix-shell.patch
- "${FILESDIR}"/${PN}-1.5.0-fdt_check_full-visibility.patch
- "${FILESDIR}"/${PN}-1.5.0-gcc-10.patch
-)
-
-src_prepare() {
- default
-
- sed -i \
- -e '/^CFLAGS =/s:=:+=:' \
- -e '/^CPPFLAGS =/s:=:+=:' \
- -e 's:-Werror::' \
- -e 's:-g -Os::' \
- -e "/^PREFIX =/s:=.*:= ${EPREFIX}/usr:" \
- -e "/^LIBDIR =/s:=.*:= \$(PREFIX)/$(get_libdir):" \
- Makefile || die
-
- tc-export AR CC PKG_CONFIG
- export V=1
- export NO_YAML=$(usex !yaml 1 0)
- export NO_VALGRIND=1 # used only in 'make checkm'
-}
-
-src_install() {
- default
-
- use static-libs || find "${ED}" -name '*.a' -delete
-}